Vero 4k+ slow on WiFi, fine wired


I’ve done some searching of the forums and while I’ve seen various mentions of slow WiFi connections, none of the resolutions seem to apply in my case.

Yesterday I replaced my venerable NUC running Openelec (Kodi build was Krypton I think, which will tell you how old it is) with the Vero 4k+. I have a very simple setup: Vero 4k+ with a powered external hard drive connected via USB for all media. I am with Sky in Ireland, on a previous gen router that only offers 2.4GHz, but speeds are always basically consistent no matter what I connect. If I do a speedtest on anything in the house I’ll nearly always get 25-27 Mbps down, and 7 Mbps up. OK.

When in wireless mode, the Vero 4k+ isn’t seeing anything like that down, it’s showing anything from <1 Mbps to 5 or 6 Mbps tops and seems very variable. Putting it right beside the router didn’t change that at all. Interestingly, the upload speeds are the same as ever, pretty solid at 6Mbps or so, which strikes me as strange. I can’t use wired where it is, but in the interest of testing I moved to a different room and checked a wired connection. No problem there, everything is back at the level I’m used to seeing.

As a player it seems to be working fine, but since my use-case involves occasional downloads via WiFi, I’m concerned that the speeds are incredibly inconsistent and noticeably slower. It’s kind of a deal-breaker as things stand.

Any suggestions? Thanks in advance!

I’d recommend testing WiFi speeds on your network, not using Speedtest which introduces an external factor.

The best you will get real world with 2.4Ghz is about 35-40Mbps which is only sufficient for 1080p.

How near are you to the router?
Have you tried changing the channel on the router?

Hi Sam, thanks for the quick response.

The most we can get here is 30 Mbps broadband from Sky anyway, so I’m used to that. On the NUC (in the same place, one room away from router but paper thin walls) I got consistent 25ish down. I’m clearly not getting that currently, even downloading add-ons was a tremendous chore. I tried moving to beside the router to test, but (wireless) speeds were unchanged. Up is fine everywhere, down is not.

I appreciate that speedtest isn’t ideal but it is at the very least consistently illustrating the problem that’s occurring. Just to be clear, no other WiFi connection in the house is showing any problems, no matter the location. The Vero is literally the only thing I’ve encountered this with. If you can suggest more in-depth tests I’ll be happy to try them. I can SSH into the box, my Linux knowledge isn’t great but it’s not zero either so happy to dive in a little.

I can change the channel on the router, sure. I’ll give that a go.

I would recommend using an iperf3 test in both directions and checking the speeds there.

I started to read about iperf earlier, but I got stuck on what to install it on as a “server”. Just any other computer around the house?

Edit: router channel change had no effect.

Choose a wired computer. Iperf3 runs on a variety of platforms, including Windows. iPerf - Download iPerf3 and original iPerf pre-compiled binaries

Check out: [How To] Check Network Performance with iperf3

Ideally the other machine is wired.


Thank you. The Vero is back in its normal place (one room away from the router) but I can test again beside to the router tomorrow. Here’s what I’m seeing in any case, with the laptop wired to the router and the Vero wireless:

Can you please upload some logs via My OSMC, or grab-logs -A and send us the url?
The connection certainly does not look stable


I think with the logs we can see what connection speed has been negotiated between the Vero and the Access point. Note that concrete walls can really have an impact on speed.
I can barely use Wifi on my terrace, yet it is 5m from my AP in straight line - and 2 concrete walls in between.

Hello again everyone, apologies for the delay, I’m just not getting time to tinker in the evenings. Sorry to be an idiot, but what would you like logs of, Sam? As in, what would you like me to do while I’m logging?

I have tested a little more this evening and proximity to router does seem to be a major factor, which is unfortunate. As posted above, I’ve been lucky that wireless with everything else I’ve used for 15 years in this house has been fine, so this is new to me. I’m streaming 4k without incident to the TV right beside the Vero, for example, and as mentioned above the NUC it replaced got speeds consistent with my broadband offering at home. It may be that the Vero just doesn’t like the location, but I’m still holding out hope that something else is going on and that we may be able to improve performance somehow.

On that note, and this makes no sense, I put the remote dongle into the other USB port and, well, speed was much quicker (15Mbps on simple speed test). Putting it back in the first port slowed it right back down again (5Mbps or thereabouts, similar to what I was seeing before). I have gone back and forth a few times now and it seems reproducible, even if it doesn’t make a huge amount of sense. (For reference, the max I’d be expecting to see is 25 Mbps or so).

So apologies that testing is haphazard, but work and kids and home life gets in the way. Again, thanks for the help here.


All logs via My OSMC are establishing a WiFi connection on a fresh boot would be useful.

The remote dongle operates on 2.4Ghz as well, but the interference should be minimal. I’ve some suggestions and it would be good if you could try them individually and report back each time:

  • You mention that your TV is right next to the Vero (obviously), and that it’s connected to WiFi. Can you try disabling WiFi on the TV and see if this helps?
  • Try hold Home and OK on the remote for a few seconds to force the remote to re-pair. This may reduce congestion.
  • If Bluetooth is enabled under My OSMC and you are not using it, turn it off.
  • If you completely remove the remote dongle and do the test – what happens to the speed?


Proper check tomorrow, but first three had no obvious effect, while removing the dongle has immediately given the quickest speeds I’ve seen in here since I started (into the 20 Mbps range). I actually spent most of the evening setting up an IR remote, so it should be usable this way. Still, I’ll send proper logs tomorrow if I can. Too late for me now!