Vero 4k stays in "energy save" mode

Hey guys,

my Vero 4k+ often doesn’t get out of the “Energy save” state and the screen stays very dark and the brightness is very low. The only way to solve it is to restart. How do I fix this?


Are you putting the device in standby?


Well “energy save” mode switches off the HDMI signal so if your screen “stays very dark” it is not in energy save mode but in “dim” state.

Are you on the latest update? Maybe try to disable the screensaver, see this thread