Vero 4K+ stopped booting and now shows only red led

Hi guys. I have a Vero 4k+ that has been working like a champ for a few years now but has all of a sudden stopped. Now, if I unplug it and plug it back in, it usually shows the red led for a few seconds and the goes out. On time it actually stayed solid red until I unplugged it again. In either case, HDMI output is null. I have nothing else plugged in except a micro sd which I removed to test.

I have tried it with the original PS and the one that I have for my older Vero 4K (non-plus). This is in two different rooms with different plugs/circuits. I have not allowed an update for at least a year or two so thing should have not really changed, AFAIK.

Anything else I can try?

Thanks.
Ernie

Hi

What was the last thing you were doing with the device before it failed?

I wonder if your system just tried to update from a very, very old version of OSMC.

Sam

Hi Sam.

The device sits in a “media” closet and is plugged into an HDMI matrix switched that distributes throughout the house. It is used every once in a while so it hard to say how long it was in the state exactly. But I can say it was no more then a few weeks.

I specifically disabled auto update for the OS. I didnt want it upgrading to the latest kodi (Leia?) because the family is used to the Aeon skin. Instead, I have been using the older 4K for testing updates which has been unstable for me but have not had time to look into that one more.

Ernie

Have you tried to connected it directly to a TV with a different HDMI cable?

Does it show up on the network? Can you connect to it via SSH or HTTP?

Yep. When I had it in the other room with the older Vero 4k, the HDMI was going to a direct input.

Nothing, unfortunately. I tried SSH. Doesnt even show up in a ping. The router shows its listing as “inactive”.