Vero 4k stopped working AGAIN

So, for the n-th time, my Vero 4k stopped working.

When I use the remote - and I’ve tried several, with and without an extra BT dongle - the screen just blinks. Any button makes the screen blink and stay blank for a few seconds before returning. And trying to play a video results in a perpetual blank screen.

Then, after a while, it wouldn’t even boot. It comes to several attempts of

[FAILED] Failed to start Bluealsa daemon.

and never gets past that.

Also, I’ve tried 6 (SIX!) different USB dongles with a new image, and every single one of them results in absolutely nothing happening when restarting the POS device. Nothing. Just a blank screen.

This is the n-th time I’ve had problems with this POS device, and I’m getting really sick of it. However, I’d like for it to be fixable, since I’ve not seen a good alternative.

Can you post a screenshot of your USB contents? From your post history, I can see that you used the wrong image last time when you had to reinstall as your device didn’t have enough free storage.

But since then, I don’t see any reports of an issue from you since September 2020. Did you open a ticket or support request?

I’m confident that we can get this solved for you promptly.

Sorry for the angry tone, but I sincerely find this frustrating, to say the least.

I’m using the OSMC installer, and selecting Vero 4k/4k+. It’s hard to get the wrong image then, I’d think?

However, the whole installation takes a few seconds (after downloading), which doesn’t seem right. And the USB pen is not readable on my windows computer afterwards, so looking at the contents isn’t an option.

I’ve no downloaded the Vero 4/4+ image directly, and selected to use the image from my local machine instead of automatically downloading. Let’s see if anything’s different…

That’s likely your problem. The contents of the SD/USB will definitely be visible after successfully
imaging the device.

Can you point me to the other issues you’ve experienced so we can address this?


So I created the install disk on another computer, where I was actually able to view the contents. Absolutely no change.

Also, quite excitingly - the error/failure when trying to boot the Vero with the existing file system changes/evolves even though change has been made. Yesterday, the error was this:

[FAILED] Failed to start Bluealsa daemon.

…and then eternal hang.

Today, the error is this:

Waiting for root filesystm device /dev/vero-nand/root

Impressive, really, that this changed apparently all by itself.

Anyway…the contents of the USB disk after creating the installer:

On the first attempt, the error when trying to boot from the USB disk was the same as without (waiting for root file system…). So it wasn’t registering the USB disk after all.

On the second attempt, creating the disk on another computer, the result is a totally blank screen, and the signal to the TV being gone.

Do you actually see the OSMC installer come up on your device?

No. Nothing at all happens when starting the device with the USB disk inserted. It simply doesn’t recognize any of the USB disks I’ve tried, and I’ve tried 6 different ones.

It simply isn’t able to recognize/read any USB disk.

I almost suspect there is a power issue on that device.
I have all the vero’s since vero 1 :slight_smile: and only problem I had was when a power supply once died.

I suspect Sam is wanting to see if a log can be taken. But next time you boot, take a good USB power supply (2A at least) and power the vero through USB (Don’t put the other power supply in).

PS: When I image a new SD-Card/USB stick, I tend to format it first!

Here’s my previous issue:

However, I seem to be talking about some buttont to hold in for 30 seconds, but I cannot find anything of the sort on the device. Nor can I find any info about it, and I don’t remember any such details.

I would indeed recommend trying another 5V, 2A PSU based on the issues you’ve described.

Don’t think I’ve got one lying around, since the Vero 4k power is not a USB micro like the ones for the Raspberry. I’ll have to try finding one.

But from your post - didn’t you have luck with another USB?

Shouldn’t be any need to use the recovery switch.

Well. This time I’ve tried 6 different sticks, so I’m not even bothering to try more.

Where is this recovery switch, though?

The toothpick method is deprecated - provided you were on a version of OSMC from over the last year