Vero 4k+ stream audio to bluetooth

Hi there,

Simple question, what is the purpose of the bluetooth module on the Vero 4k+ ? Is it meant for streaming from a bluetooth device (say a phone) to the Vero, or is it meant for the Vero to stream to the bluetooth device (say a bluetooth speaker) ?
I wish to do the latter but never managed to make it work. Bluetooth devices are seen but there are almost always some connection problems and even when connected no sound comes from the Vero.
If it’s not possible then for me the bluetooth module is almost useless. And if so, is there a workaround, like an additional bluetooth dongle ?


Have you tried setting up bluez-alsa according to this?

Thanks for answering right away :slight_smile: I will give it a try.

Can’t seem to find .asoundrc.example file in osmc home directory. Tried locate .asoundrc.example with no success. Can you tell me where is it located ?

It should show up with ls -a ~/

Nope. Is it in the root home directory ? I’m in the osmc home directory.

hang on. Did you install from the testing repo or from my .deb?

You just need to create a file in the osmc home directory that looks like this and call it .asoundrc

pcm.jblflip {
type plug
slave.pcm {
        type bluealsa
        device "FC:A8:9A:B3:42:4F"
        profile "a2dp"
        hint { show on description "JBL Flip 3"}

Substitute any text for jblflip and “JBL Flip 3” and substitute your device’s address for FC:A8:9A:B3:42:4F.

.asoundrc.example seems to have gone missing from the repo. I’m worried there are other files missing - let us know how it goes.

Just typed “sudo apt-get install pulseaudio-module-bluetooth pulseaudio”. Maybe I missed something ?

Can’t test right now, the woman is using the tv.

Oh dear. Where did you get that from? You will have to remove pulseaudio for this to work.

Yup sorry, misread your doc and missed the point alsa was included in v19.