Vero 4k Stuttering & Buffering when playing 4k

I’ve seen a few similar other posts about Vero buffering issues which I’ve read and either not understood sufficiently or don’t apply to my scenario.

I play files from a USB3 drive that is inserted into the Vero. When I play 4k UHD files I get buffereing and choppy playback. Below is the link to the log file and the MediaInfo files for two different films.

Thanks in advance for any help given.

I’d guess it’s because your USB3 drive isn’t ext4 formatted. I can’t get high bitrate files to play smoothly from NTFS even with a SSD attached to USB.

Thanks. Giving that a go now, will report back.

Unfortunately that’s not made any difference.
Here’s the log file from that attempt
While debugging is enable the info for the CPUs on the screen shows them maxed out at 100% which i guess why i’m getting a stuttering picture and buffering.

Two things:

  1. The mediainfo you showed before indicates it is a Dolbyvision File which the Vero can not play (while I would not expect stuttering but false colours)
HDR format                               : Dolby Vision
  1. Seems you have an overscan issue, the below for solution

It seems you have a issue with Overscan. Ensure that you did not have any calibration configuration in Kodi/OSMC and use one of the following methods depending on the TV Brand you use.

  • Samsung TV - go to Menu / Picture / Picture Options / Size / Screen Fit (instead of 16:9).
  • LG TV - go to Settings / Picture / Aspect Ratio / Just Scan (instead of 16:9)
  • Sony TV - hit Home button, go to Settings / Screen / Display Area / Full Pixel
  • Sharp TV - hit View Mode button, select “Dot by Dot” or “Full screen”
  • Sharp Aquos - go to Menu / System Options / View Option / View Mode / Dot by Dot
  • Panasonic TV - go to Menu / Picture / Screen Settings / 16:9 Overscan / Off

Thanks for the tip but that hasn’t worked either. I didn’t used to have this problem as I’ve played many 4k films on the Vero without any issues. So either there’s something wrong with the content that I’ve been playing recently or maybe a recent update?

Any other suggestions?

Can you upload new logs?


Hi Sam,
Thanks for having a look. New log below…

Thanks for your patience.

I’ve taken a look at the logs.

Hardware acceleration isn’t working because of this error

2022-01-11 16:29:05.419 T:2880     INFO <general>: CVideoPlayerVideo::OpenStream - Creating codec: 173
2022-01-11 16:29:05.419 T:2880    ERROR <general>: AML: no proper permission, please contact the device vendor. Skipping codec...

Can you try running:

sudo apt-get -f install – it’s possible your kernel hasn’t updated properly.

A reinstall will definitely solve this, but it’s best to avoid that for you if possible.

Hi Sam,

Thanks for the time you spent in looking into this for me. The command you asked me to run has fixed the issue I was experiencing. :smiley:

I’m glad to hear this. It seems you had a partial update installed on your system.

Since the recent update to fix the HDMI CEC issue I’m experiencing buffering issues again, thinking it’s for the same reason as before I tried running the sudo apt-get -f install again but I got the following message…
The following packages were automatically installed and are no longer required:
armv7-libass-osmc armv7-libnfs-osmc dh-python gnupg-agent libapt-inst2.0
libbind9-140 libbind9-161 libcdio13 libcdio18 libcryptsetup4
libdevmapper-event1.02.1 libdns1104 libdns1110 libdns162
libdouble-conversion1 libegl1-mesa libenca0 libevent-2.0-5 libevent-2.1-6
libfdk-aac1 libffi6 libfile-copy-recursive-perl libgdbm3 libgeoip1
libgles2-mesa libhogweed4 libicu57 libicu63 libidn11 libip4tc0 libip6tc0
libiptc0 libisc1100 libisc1105 libisc160 libisccc140 libisccc161
libisccfg140 libisccfg163 libiso9660-8 libjson-c3 liblvm2app2.2 liblwres141
liblwres161 libncurses5 libnettle6 libnfs12 libntfs-3g871 libpcre16-3
libperl5.28 libprocps6 libprocps7 libproxy1v5 libpython2-stdlib libpython2.7
libpython2.7-minimal libpython2.7-stdlib libpython3.7 libpython3.7-minimal
libpython3.7-stdlib libssl1.0.2 libunistring0 libwebpmux2 libxcb-util0
libxext6 libxi6 perl-modules-5.28 python-pkg-resources python-six python2
python2-minimal python2.7 python2.7-minimal python3-distutils
python3-lib2to3 python3.5 python3.5-minimal python3.7 python3.7-minimal
update-inetd wireless-firmware-osmc
Use ‘sudo apt autoremove’ to remove them.
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.

Here is the log file I uploaded.

Your system is not up to date.

I’d suggest updating it.


Strange, I’ve just updated to the October release?
Thanks for your reply, but I’ve decided to go back to the March release so that my HDMI CEC issue can be resolved.