Vero 4K Stuttering on 1080p Remux

Hi. I just encountered stuttering on a 1080p remux. I’m using 2018-12.1 version on the Vero 4K. Also tried on Vero 4K+. Played via USB drive.

Logs -

Media info -

Can anyone who’s using the current beta try this out and see if there’s stuttering too? Thank you very much!

Format : MPEG-TS

Have you tried remuxing to mkv ? with

@k2u3 - I just realized the clips I posted are all running smoothly now. Could it just be a bad remux?

Well the media info you posted shows the original file is not a matroska .mkv but TS ( transport stream) If you made the samples using mkvtoolnix or makemkv and they play smoothly that would explain why.

Just remux the original file in full not just clips of it.

I downloaded the clip and looked at media info and it says

Format : Matroska while the media info of the original says Format : MPEG-TS

@k2u3 - so just remux the whole file using mkvtoolnix and see what happens? I split the TS using mkvtoolnix with default settings. Should I change something in the setting?

Just remove the split settings and remux the file in full and it will ( or should) play fine

Thanks, @k2u3

Any idea why it plays fine (without remuxing) on other players? VLC, Zidoo, Shield?

Not really. You’d have to ask @grahamh or @sam_nazarko or someone else that understands how kodi works. I was told that matroska provides some meta data to the player upfront that probably helps but I’m just guessing

1 Like


Also, remuxing the file made it smaller. TS is 38.4GB, MKV is 37.2GB

1 Like