Vero 4k: Stuttering when replaying 4k hevc files / Help Fstab mounting an NFS share - SOLVED

[edited to solution]


I’ve got (and love) a couple of Vero 4K’s but noticed that they have an issue playing 4k hevc files.

Looking on the forum I saw a suggestion to fstab mount my NFS share folder. However, I run into issues attempting to do so with;

  1. sudo mkdir mnt/film
  2. sudo nano /etc/fstab
    inserting “ /mnt/film nfs x-systemd.automount,noauto,user,rw 0 0”
  3. sudo mount -a (new prompt with no errors returned)
  4. sudo systemctl daemon-reload
  5. sudo systemctl restart
  6. cd /mnt/film response = now works perfectly!

However, if I just enter sudo mount /mnt/film then I receive no errors and ls shows my Nas Films directory.

Apologizes if I’m missing an obvious error, my Unix knowledge is very basic so just followed this from instructions from similar forum posts.

Any help troubleshooting greatly appreciated!

Best, Mark

Try without the nfsver=3 part.

Thanks for commenting.

Removing nfsver=3 doesn’t seem to make any difference unfortunately (“sudo mount -a” still gives no errors, but end up with same “no such device” result)

Opps, I missed this! The fstab line should be: /mnt/film nfs x-systemd.automount,noauto 0 0

EDIT: I removed the nfsver=3. Add it back if needed.

EDIT2: You may also want to add the options user and rw (user == allow user to mount, rw == read/write access). Also, while I don’t think it’s required, add 0 0 to the end of the line. /mnt/film nfs x-systemd.automount,noauto,user,rw 0 0
1 Like

Is that a typo? It should be sudo mkdir /mnt/film

Possibly related to point 1. Run ls -la /mnt The mount point should be there, even if the mount has failed.

1 Like

This works perfectly! Thanks so much really appreciate the quick and really helpful responses.

I’ve edited my original post (also correctly the typo dill pointed out), just in case of use to any other newbie - as this completely fixes the stuttering issue I’d been having for 4k files.