Vero 4K+ suddenly no signal and ethernet connection

I’ve been using Vero 4K+ for a while without issues. However today, it just suddenly stopped working seemingly. My TV and my soundbar do not detect an hidmi signal and the vero is also not active on my local network. It’s displayed as offline.

Ths morning (after using it successfully yesterday) it suddenly showed no signal, and there was no light on on the device. I plugged the power cable in and out, and now it’s constantly showing a red light on the front, but still no signal or ethernet.

What can i do to get it working?

1 Like

See if you can use a different power-supply.

Tried 2 others but same thing.
Also tried connecting it to a pc through usb, but it didn’t show up in device manager or the osmc installer.

PC won’t work. 2Amps are required on the power supply.
Eventually @sam_nazarko may be able to help you out here.

PC will work if both ends of the cable are USB A

Ive got a double ended usb a cable but it doesn’t show up in device manager or osmc installer.

It will only show up in Device Manager if you connect it to the white port

Yup, that’s the one I’m using, The front light is red just like when the power is plugged in.

If the device is not even detected at all that isn’t good. It may have died. Did you have a power surge recently or storm?

No nothing like that happened. I was using it until yesterday evening without issue. Then no storms or electrical outages, but this morning it wasn’t giving any signal.

I tried different USB ports, but with every one the red front light stays on, and nothing is visible in windows.

Hard to say – you could send it back for me to take a look at, but I can’t guarantee I can fix it. We don’t stock many Vero 4K + parts anymore.


Well, if you have little faith then I doubt it’s worth it.
Isn’t there anything I can try to reset it?

Once the Vero is hooked up by USB to a PC, should it pop up immediately? Or only in device manager? Or should it be directly visible in USB Burning tool?

Is there anything you can do? I know the warranty is gone, but it is disappointing that the device just gives in on its own in under 3 years.

You could send it back and I can take a look at it, but I can’t guarantee it can be fixed.