Vero 4k+ that won’t turn on

Hi, I have a Vero 4k+ that won’t turn on.
When plugged in, it goes to the red light and then turns off.
I’ve tried a few alt ac adapters in the office yet none will even turn the unit on.
Not sure what else there is to do since I can’t get it online to grab logs or troubleshoot.
Would it be possible to either get a replacement ac power adapter to make sure or would it be possible to have the unit replaced?
Any other suggestions welcome.

If the light is turning off after a couple of seconds, it is booting as expected.

You could try reinstall OSMC or try the device on another display with a different HDMI cable.

Can you show a photo of the other power supplies you’ve used?

How would I reinstall OSMC if the device never stays powered on? It only shows the red light then goes out, never goes to blue light.
Have also tried at 2 diff tvs and 2 diff hdmi cables.

Last power supply i could find was similar but not exact with specs:
Input: 100-240V ac1A
50/60Hz, 50-80VA
Output: 3A max

You are omitting the most important aspects which are output voltage and polarity.

Vero 4K+ doesn’t have a blue light. The red light should turn off 1-2 seconds after applying power to indicate a successful boot.

Well, that’s embarrassingsigh it’s my dad’s player (mine is a 4K).
I’ll continue to troubleshoot, so it’s getting power but no display then.
I’ll see if it’s hitting my network and try to connect to it that way.
Appreciate you putting up with dumb questions :face_with_diagonal_mouth: