VERO 4K Turns my TV on when I turn my receiver off

I have an issue with automatically turning on my LG TV when my receiver is going off.
The TV is connected to my Denon receiver and Vero 4K is connected to my Denon receiver as well.

  1. TV and Vero 4K is on
  2. Turning TV off change Vero 4K to sleep mode (it works)
  3. Turning my receiver on doesn’t change the sleep mode on my Vero 4K (it works)
    4) Turning my receiver off turns Vero 4K on and turns my tv on (receiver is still off) - why?

You can see that on this video:

My CEC settings:

Any ideas?

Turn HDMI cec on the Vero off

This is quick win solution, it turns off many features as well. What is the final solution?


Other than turning of cec, the only thing that may help; is just to leave the vero on rather than have it go to sleep.

Thanks Tom.

With CEC disabled. That would be strange/ Can you upload debug logs of that happening?

I reacted on Tom_Doyle post:
“Other than turning of cec, the only thing that may help; is just to leave the vero on rather than have it go to sleep.”

It does’t work. Vero still turning my TV on :-(.

Try connecting the vero directly to the TV and see if the problem goes away

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

Mine’s the same. I think it’s an issue between the Vero and Marantz/Denon amps. My solution was to turn the TV to TV mode (rather than HDMI) before switching off and then turning the amp to “not Vero” before switching off. Leave the vero always on because anything seems to switch it back on and its “on” signal then switches other things back on.
I have a feeling that switching the amp off puts it into pass-through mode and the TV thinks that the vero has just been switched on.

In the setting of the Denon AVR look for something like video>hdmi setup>pow off control> and turn it off.

But in this case turning TV off will not turn Denon AVR off.
The issue must be somewhere in Vero 4K, coz I have Playstation 4 and Apple TV connected to my receiver without any issue like that.

In the Kodi CEC settings, if you set “when the TV is switched off” to “ignore” instead of suspend and then reboot the Vero does that make a difference?

thx a lot for your try to help me.
Here is my log:!AhuEv-cd1TeLh59U041e3Mw0G-fLUw?e=FdcAiK
I made a clean installation => Logging => 2x reboot
I found this line: 2020-04-24 12:27:28.816 T:4060082912 DEBUG: CEGLNativeTypeAmlogic: Detected HDMI switch
in the end of the log.


Well, this is not “solution” :-). I have PS4 and Apple TV connected to my Denon and there is no issue, only Vero 4K makes this trouble :-(.

As outlined above we have methods for submitting propper logs

The settings I use without issue on similar hardware are…

Device connector> hdmi 2 set to home theatre using ARC, with both Simplink and auto power sync enabled. I have found that if I connect an AVR to any other input on this TV, even if i’m not using ARC, I get odd behavior (I forget the details).

Denon AVR
setup>video>HDMI setup>

HDMI audio out>AVR
HDMI passthrough>on
pass source>Last
RC select>source only
HDMI control>on
TV Audio Switching>off
power off control>all
power saver>off
smart menu>off

settings>system>input>peripherals>CEC adapter>

switch source to this device on startup>[on]
devices to power on during startup>TV
devices to power off during shutdown>TV
send inactive source command on shutdown>[off]
put devices in standby mode when activating screensaver>[off]
wake devices when deactivating screensaver>[off]
when the TV is switched off>ignore
devices to also put in standby mode>[off]
use the TV’s language setting>[off]
action when switching to another source>pause playback
physical address>0
force AVR to wake up when Kodi is activated>[off]

NOTE: When CEC settings are changed in Kodi a full system reboot is often required for the settings to take effect.

Obviously when I say “solution” I really only mean workaround/bodge than only really lasts a few days until without warning I’m back to the situation where every time I switch something on or off I have to wait around a few seconds while the devices decide to change to another setting and I have to force it back; but it doesn’t take more than three attempts before I can accept that it is then set how I want. I also had no issues with the Bluray, Firesticks, PVR, previous media player.