Vero 4k+ (U)HD & non- HDR content super dark

Https:// with html behind it is what im getting, dont suppose that is correct

That means that your logs are to large. Reboot twice and that will clear the logs. They reproduce again and post logs.

Just reboot the device, play the file. When it doesn’t play, upload the logs.

Thanks again for the time invested;

The log is set for the settings I think are correct, with 50/50 brightness and contrast.
In the meantime the clip magicly started to play.

But if I compare the 2 clips it is as if the HDR clip is being played in HDR but only 8 bit (banding in the sky)
If I play it in the internal LG player, the sky is perfecly smooth. (And brighter)

It’s not playing BT2020.

Jun 16 09:16:23 osmc kernel: hdmitx: video: Bit depth: 10-bit, Colour range RGB: full, YCC: full, Colourspace: YUV422
Jun 16 09:16:23 osmc kernel: hdmitx: video: Colorimetry: bt709



I fixed the banding (no idea how), but the image is still barely watchable dark at times.
Another issue Im expierencing is that when Im not using the Vero (off, standby or on) my tv cant send audio to my receiver. As soon as I disconnect the power from the unit it works again.

Thanks for the log. Did you stop and re-start the video? This is doing my head in.

Lack of ARC is a known issue. Try turning off CEC on Vero Settings/System/Input/Peripherals/CEC Adapter.

I realised that I set the HDMI on a different setting to try stuff. Once I turned it back, the problem of the banding was gone.

But like i said the IQ is still dark. Will add some photos of the issue tomorrow (LG internal vs Vero)

I will try the HDMI CEC setting once at home.

Found the banding issue - should be easy to fix - surprised no-one else has reported it.

What is the exact model of your TV?

It is the LG OLED55C7V.

Hi, I have the same LG OLED55C7V and a Marantz SR7010 AVR. I have played The World In HDR file and I don’t see any banding…
And I think there are some picture quality differences vs internal LG player, picture seems to be darker on the Vero.

set 1 (vero top, internal LG OLED player down)



Thanks for that. Hard to say which is ‘correct’.

Here are two images of an other HDR content;
Vero Top, LG bottom

In some scenes, you cant even make out who or what is on screen in my case.

Ouch, I am sorry. I think my last post is pointless because of different picture mode in TV settings. Vero HDMI input is set to “Technicolor expert” preset and LG internal player was set to “Standard”, beacuse I have never used it before. After setting both to “Technicolor” or both to “Standard” it looks the same. Sorry for that, that’s embarrassing :wink:

@Excessed please, check the preset mode and make sure the are the same on both Vero input and LG internal player

Well, if you look at the colour of the wall behind the screen, it seems your camera was set to a different exposure for each so it’s hardly a fair test.

Also, having the de-bug info on-screen might be making the LG think too hard about an appropriate colour level for the whole picture. Not as bad as my back-lit LED would but there could be an effect.

@sojer2005 they are exactly the same
@grahamh you’re right, didnt notice before.
Tomorrow i’ll take some good photos with my dslr and a tripod.

On the same picture preset “Technicolor Expert”. Looks the same, don’t they?
Vero on top, LG internal player on bottom.

1 Like

So, long story short; It works as it should now with HDR. Same brightness as the internal player. The problem was in a setting I changed the moment I got the TV. The dynamic contrast was on Off instead of Low.

Only SDR is still very dark, but that I can play with the internal player of the tv.

So thanks for the awesome service and help, I can now use the Vero for what I bought it for; Playing 4k HDR trueHD content!

I’m glad to hear this.
SDR-> HDR is a feature we’ll look at adding in the future.


Hopefully we will get improved HDR-> SDR first