Vero 4k+ (U)HD & non- HDR content super dark

Installed my Vero4k yesterday, and performance wise I am very pleased with it.

The one issue I am having is that ALL the content (4k, 1080) and (SDR and HDR) is so dark it is unwachtable at times.

I own a 4K HDR Oled (LG) and I can raise brightness on the Vero. But if I do that the black levels are gone.

Tried alot of things already. Like the limited colors, other hdmi inputs but nothing works.

If I play the content on my TV or Xbox everything is fine and vibrant. Only the Vero has this issue.

The vero is connected to my Marantz AVR, and then to the TV. But also directly to the tv gives this issie.

Does someone have the magic trick?

Please post some logs so we can check a couple of things.

Hopefully I did it right;

No, that’s not the correct way.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device

  • reproduce the issue

  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

Thanks, will try that as soon as I get home tomorrow

So this is the log, created as specified above.
Hopefully it can be fixed, dont want to return the vero.

you need to post the URL you got on the vero screen

Ah crap, forgot the actual url.

I can’t see anything immediately that might cause the issue. Could you just revert all the Kodi settings to default as a quick check? as follows…

Get a commandline using ssh, and type:

sudo systemctl stop mediacenter
mv ~/.kodi/ ~/kodi.bak
sudo systemctl start mediacenter

Test some videos, and if there’s no difference, you can revert with:

sudo systemctl stop mediacenter
rm -r ~/.kodi/ && mv ~/kodi.bak ~/.kodi
sudo systemctl start mediacenter

That did not make a difference unfortunately.

Have you got any other TVs in the house you can test on? I can only think there is some setting on the LG which isn’t right. IIRC Xbox puts out RGB, not YCC so settings will be different for that and playing a video from USB or network on the LG will by-pass any HDMI settings.

I only got the LG tv

Please double-check the settings for that input on the LG.

BTW, you’re not using Plex for these tests, right?

Settings are all good. And Im using the kodi/osmc player for the tests.

The issue will almost certainly be settings related.
As a quick test, please try connecting the device directly to the LG TV and bypass the Marantz AVR.
I also recommend trying a different HDMI port on the TV.


Don’t forget, also test a different HDMI cable, for completeness :wink:

Done both, and still the same issue.

I think you should try a video that we frequently use.
See The World In HDR UHD 4K Demo | 4K Media.

It looks like you have your GUI set to 4K.
Please set it to 1080p, make sure Adjust Refresh Rate is enabled and try play the above file.

Set it to 1080p and the refresh rate was on.
And the clip wont play somehow. Works fine on the internal player of the TV, but the vero wont play it

Please post a debug log when it doesn’t play.
Same procedure as before.