Vero 4k+ unable to connect to internet (wired or wireless)


I have been using my vero 4k+ without any issues for 2 years so far. Today I see that it is unable to connect to the internet. I usually connect via wifi, the IP address on the my osmc says 169.x.x.x and the status is no internet. I tried connecting via the ethernet port and I still see the same problem with a 169.x IP address and status: eth0 (no internet)

Any other troubleshooting steps I can do? Since I can’t ssh into the machine I’m not sure what I should be doing next.


This suggests a DHCP issue.
Anything new in terms of router or modem?

Could you try rebooting your router and then your Vero when the internet is back up?

Does connecting via WiFi work?


Hi Sam, thanks for the quick response. I was unable to connect via wifi either. I didn’t consider that it could be an issue with the router since other devices on the network were able to access the internet.

But I tried resetting the router and I can now see the vero getting a DHCP address assigned correctly. After that the vero was still unable to access the internet perhaps because both wired and wireless connections were enabled. After disabling the wired adapter it was successfully able to connect to the internet. Appreciate your help with this issue!

Glad to hear this is now solved.

If you have any further issues, do let me know.