Vero 4K unable to mount via fstab - it was working before

Hi all,

I am trying to mount my 4K Movies via fstab, if I use the normal SMB Share 4K files (30GB+) do not play correctly and most of the time black screens with music stuttering play with the TV constantly switch back and forth to HDR.

I have previously connected my 4K movie share successfully via fstab, I am rather confused as I have not made a changes.

For reference I am using the following step by step guide: Configuring fstab based Samba share mounts

My /etc/fstab file line 3 reads as this:

// /mnt/4K_Movies cifs x-systemd.automount,noauto,rw,iocharset=utf8,username=MyUserName,password=MyPassword,uid=osmc,gid=osmc,file_mode=0770,dir_mode=0770 0 0

After trying to mount the device:

cd /mnt/4K_Movies

I received the following error:

-bash: cd: /mnt/4K_Movies: No such device

Then I tried the following:

osmc@osmc4K:~$ sudo mount /mnt/4K_Movies
Couldn’t chdir to /mnt/4K_Movies: No such device

If anyone can give me a few pointers that would be great!

Did you try different SMB versions as the tutorial suggests? I’d suggest trying vers=2.0 or vers=3.0 to the fstab line.

I will give that ago, I assumed that was for guest mode only?

No that can be used when specifying credentials like you are.

You Sir know what you are talking about! I am able to list all the films so I bet it works now! Brilliant, maybe we can get someone to update the guide to include the vers as standard? 2.0 worked for me connecting to a windows 7 share.

1 Like

I don’t want to add vers= as part of the default as it’s not always needed. I can clarify that the option can be needed even if using credentials.

How’d it go?

I have played a few short clips and everything is fine with the fstab!

I decided to also go through all my HDMI cables and found one which was causing the black screens / HDR issues. Now it’s onto figuring out the strange slight HDR banding issues but currently I am very happy :slight_smile:

1 Like