Vero 4K unable to update

my osmc is acting up.

this is what happens when I try to update via command line

how do I fix it?


osmc@osmc:~$ sudo apt-get update
Ign:1 http://ftp.debian.org/debian stretch InRelease
Get:2 http://security.debian.org stretch/updates InRelease [94.3 kB]
Ign:2 http://security.debian.org stretch/updates InRelease
Get:3 http://ftp.debian.org/debian stretch-updates InRelease [91.0 kB]
Ign:3 http://ftp.debian.org/debian stretch-updates InRelease
Get:5 http://security.debian.org stretch/updates Release [92.7 kB]
Err:5 http://security.debian.org stretch/updates Release
Error writing to output file - write (28: No space left on device) Error writing to file - write (28: No space left on device) [IP: 151.101.112.204 80]
Hit:6 http://ftp.debian.org/debian stretch Release
Get:7 http://ftp.debian.org/debian stretch-updates Release [89.4 kB]
Err:7 http://ftp.debian.org/debian stretch-updates Release
Error writing to output file - write (28: No space left on device) Error writing to file - write (28: No space left on device) [IP: 130.89.148.12 80]
Err:8 http://ftp.debian.org/debian stretch Release.gpg
At least one invalid signature was encountered.
Get:4 http://ftp.fau.de/osmc/osmc/apt stretch InRelease [4664 B]
Ign:4 http://ftp.fau.de/osmc/osmc/apt stretch InRelease
Get:9 http://ftp.fau.de/osmc/osmc/apt stretch Release [4142 B]
Err:9 http://ftp.fau.de/osmc/osmc/apt stretch Release
Error writing to output file - write (28: No space left on device) Error writing to file - write (28: No space left on device) [IP: 131.188.12.211 80]
Reading package lists… Done
E: The repository ‘http://security.debian.org stretch/updates Release’ does no longer have a Release file.
N: Updating from such a repository can’t be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: The repository ‘http://ftp.debian.org/debian stretch-updates Release’ does no longer have a Release file.
N: Updating from such a repository can’t be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: http://ftp.debian.org/debian stretch Release: At least one invalid signature was encountered.
E: The repository ‘http://apt.osmc.tv stretch Release’ does no longer have a Release file.
N: Updating from such a repository can’t be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

osmc@osmc:~$ sudo apt-get dist-upgrade
Reading package lists… Done
Building dependency tree
Reading state information… Done
Calculating upgrade… Done
The following packages will be upgraded:
curl libcurl3 libprocps6 procps
4 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 787 kB of archives.
After this operation, 0 B of additional disk space will be used.
E: You don’t have enough free space in /var/cache/apt/archives/.

It appears you are out of space.
What is the output of df -h?

Install ncdu sudo apt-get install ncdu to investigate which folder is using the space.

After a reboot im unable to access it and i get a sad face at boot up and it freezes there
What shall i do now?

No ssh access? If that’s the case, probably just reinstall.

It sounds like you’ve ran out of space.

There are other ways to access the command line, see https://osmc.tv/wiki/general/accessing-the-command-line/, but this may be tricky

Sam

why is the USB option grayed out?
image

installer window is also too small to read the options clearly.

I dont have an SD card
please advise

tried to install it but it says “you dont have enough free space in /var/cache/apt/archives/”

I didnt install anything, but it started to act like this after the power went down couple of times.

I do have access to the command line now. what should I do to have it fixed or reinstalled?

Figure out what takes up the space and delete it.
To figure out what uses the space you can use ncdu as written by @actiona but before you install it you need to make some space.
So first step is run df -h to figure out how much is free on /.

Than try to delete either some Movies if you copied any onto the Vero or delete stuff in .kodi/temp/

That could indicate a filesystem corruption instead of running out of space. But the df -h will tell you. Share the output of the line with /

Actually just saw in your other post that you were able to upload logs.

The logs show enough free space (12G) so that’s not the problem. But maybe filesystem corruption.
So a clean reinstall might be suggested.

Hi @Muheeb_Alzaki – the storage options are greyed out because the settings refer to internal storage. So stay with SD card and you can use either a USB or SD card.

Run

sudo touch /forcefsck
sudo reboot

If there’s a filesystem issue, it will attempt to fix it. Otherwise I recommend a backup and reinstallation.

I tried this and it didnt help,

I have the osmc in usb but osmc will not detect it, is there a way to force it?

I assume that refered to @sam_nazarko advice to run forcefsck. So no errors where found after reboot?

Are you sure the data is written correctly on the USB stick?
Otherwise try the toothpick approach?

https://osmc.tv/wiki/vero-4k/reinstalling-osmc/

Take a screenshot of the USB please

I bet it’s something in /home/osmc using all the space. Try

$ du -h /home

I followed the procedure but I downloaded the disk image locally as it was giving me error when I used it directly from the osmc installer, it gives an error when it tries to download it directly from the net

maybe I downloaded it the wrong disk image, I will try it gain