Vero 4k unmounts my USB drive randomly


I have problem with Vero 4k. After some time it unmounts my WD usb disk and I need to reconnect it with my D-Link USB Hub.

It’s not a big problem but maybe there is some ssh command to mount it again or there is some option that unmounts disk when not used with I can disabale?

Best regards

Is the usb hub providing sufficient power to the drive ? Is the drive self powered or is it powered through usb ?

Have you tried connecting it to the vero directly? ( only do this if it’s self powered)


Disk is not self powered. I provide power thrue usb hub - this ig goood D-Link hub. I’am using two drives but only one is unmounting randomly (mayby that’s why I am using mostly the second one)

Best regards

Have you tried removing the working drive from the hub and just keep the disconnecting one plugged into the hub ? That way you could exclude a possible power shortage issue

Yes I tried

This also happens

There is some ssh command to Mount drive if that happens?

I’m sorry! That’s beyond my skills But I’m sure a technically advanced user or support staff will offer advice soon

Also for fastest possible support I recommend you provide logs how to do it you can find here How to submit a useful support request

Thx for help

Best regards

How do you determine the disk is unmounted? Could it just be that it is sleeping and need a moment to wake up?

Since I’ve had this issue from time to time too, I’m starting to wonder if it’s the hub that is the culprit. I too got a D-link Powered Usb hub, D-link DUB-H4 is the model.

I’ve changed PSU for the Hdd in question, change USB2->Sata converter, tried with another Sata disc. The only factor that has always been the same is Dlink hub + Archive disk connected to my Vero4k.

I can’t see it in windows network and with ssh command and also in File manager in Vero 4k

I have the same hub model

Maybe it is a real problem

Thx for info

I had a similar problem a few weeks ago with a different hub on my desktop (running Linux Mint).
It would hang on boot trying to mount one of the three drives connected to a powered USB 3.0 hub. If I disconnected the drive from the hub it would boot. Then I could connect the drive and it worked perfect.
Since there was a port on the hub not in use, I moved the drive to that port. Problem solved. Reboots were no longer hanging.
Moral of the story: USB hubs can fail in strange ways.