Vero 4K+ update after 2 years has left me stuck

Red faces here as I tried to bring my Vero4K+ back to life after being off for a couple of years. I have managed to update and get the system working but couldn’t get iPlayer to work as I get an error each time.

I stopped it and went to store with a view to downloading a new version.
The app store didn’t open and I cannot remember all the business of installing BBc iPlayer. Please could somebody point me in the right direction when hopefully it will all come back to me!.

First thing I’d suggest is to post logs so we can see if you’re indeed up to date.

Hi Sam, sorry to be such a dunce. I tried to enable the logging but get the message Could not retrieve URL. Will search for the How to.
I couldn’t get to the device using SSH either so I need the log.

I have plugged in a lan cable and now have a paste address. Will you be able to get it automatically or do you need the name. The paste was to
irebequtes

Hope this is what you need and many thanks.

So it seems before you didn’t had a network connection. Could that have been your problem? Does iPlayer addon install now with the LAN cable?

I had the lan connection for the upgrade but needed to get the wifi working so after the upgrade I coudn’t get this to work with cable plugged in. Now it is plugged in again I still cannot find any apps in the app store and cannot find to enable the iPlayer again.

iPLayer is an addon (Settings → Addons) not in the MyOSMC - AppStore.

There aren’t any apps in the app store because (most of the time) the Vero 4K+ is only designed to run one app: Kodi. If you want to access iPlayer on it, you can’t use an iPlayer app; you need to use an iPlayer add-on for Kodi.

If you think that’s installed already, then you can find it by going into Settings, Add-on browser, My add-ons, Video Add-ons and then look for “iPlayer www”. If it isn’t there and you need to install it, then try Settings, Add-on browser, Install from repository, Kodi Add-on repository, Video add-ons and find iPlayer www.

Duh!!! I had forgotten all this. Now enabled and working perfectly so most of the update worked perfectly.

I still have a problem using an hidden SSID. I can get a visible SSID connection to work but the one I want to use and which I use to avoid unauthorised folk interfering is hidden and I cannot get it to connect. Is this a know problem?

Still stuck with Hidden SSID. Visible SSID no problem but no joy with the hidden. However if I connect with lan cable I can now ssl into the device. How can I check the wifi connection from cli please?

Still stuck. I used the connmanctl commands as per previous threads but the connection is a managed connection and is refused. Is this a problem because of my Wifi AP settings or something I had not seen/

Can you clarify what you mean by this?

What’s the output of the connmanctl commands?

Hi Sam, It may be appropriate to split this thread since my original post has been answered.
I am now connected using lan and ssh. Here is what I have so far.

Blockquote
osmc@Restaurant:~$ connmanctl
Error getting VPN connections: Rejected send message, 2 matched rules; type=“method_call”, sender=":1.47" (uid=1000 pid=8492 comm=“connmanctl “) interface=“net.connman.vpn.Manager” member=“GetConnections” error name=”(unset)” requesteconnmanctl> agent on
Agent registered
connmanctl> scan wifi
Scan completed for wifi
connmanctl> services
*AO Wired ethernet_c44eac28259a_cable
*AR Errichel_Guests wifi_10d07ab25362_457272696368656c5f477565737473_managed_psk
wifi_10d07ab25362_hidden_managed_psk
DIRECT-cg-FireTV_d822 wifi_10d07ab25362_4449524543542d63672d4669726554565f64383232_managed_psk
BT-ZWCKZM wifi_10d07ab25362_42542d5a57434b5a4d_managed_psk
BTWi-fi wifi_10d07ab25362_425457692d6669_managed_none
DIRECT-CV-FireTV_a368 wifi_10d07ab25362_4449524543542d43562d4669726554565f61333638_managed_psk
BTWifi-X wifi_10d07ab25362_4254576966692d58_managed_ieee8021x
connmanctl> connect long-service-name
Error ‘connect’: Invalid argument
connmanctl> connect wifi_10d07ab25362_457272696368656c5f477565737473_managed_psk
Error /net/connman/service/wifi_10d07ab25362_457272696368656c5f477565737473_managed_psk: Already connected
connmanctl> connect wifi_10d07ab25362_457272696368656c5f477565737473_managed_psk
Connected wifi_10d07ab25362_457272696368656c5f477565737473_managed_psk
connmanctl>

Blockquote

I have two problems. I have no idea how to disconnect the Errichel_Guests which is working fine but I want to disconnect so I can connect to the hidden SSID

I tried using the connect the long name again and lo and behold it worked. My screen now however displays the hidden SSID and shows it connected. Nearly there but how do I remove the now un-hidden SSID?

If disconnect is not working for you, you can just remove the entire folder
sudo rm /var/lib/connman/wifi_10d07ab25362_457272696368656c5f477565737473_managed_psk