Vero 4k update

I have a Vero 4k with OSMC dated 2019, trying to update.
On a Mac, I ran the DMG, and copied the resulting data to a USB drive.
Inserted the loaded USB drive into Vero 4k, re-booted, did see some text but quite quick to read, system then booted up, but still running 2019 version.
This is what is on the USB drive:

I tried to copy the OSMC log, but not sure how to share it here - apologies just felling my way around a little!

Any help, comment appreciated!


Run the osmc installer to create a bootable drive or can you not just manually update from the osmc update.

A system that has not been updated in that long will not update to current and will require a clean install.

yes that’s right - when I try to manually update I get a message to contact OSMC forums for help:)

Do you know how to use SSH?

Hi Sam, short answer is no I don’t know how to use SSH.

But I’m looking and reading a little to see what is is!

This should help…

Or the quick answer if your using a modern version of Windows, hit the start button, type “cmd” and hit enter. At the command prompt type in “ssh osmc@<ip address>” and then enter “osmc” when it prompts you for the password. In Kodi system info settings screen you will find the IP address.

Once connected to the terminal on your OSMC device you can use the following command to update…

sudo apt-get update && sudo apt-get dist-upgrade