Vero 4K+ USB ports/mounting problem

Vero 4K+ working perfectly from January 2019 to now.
I use an external WD 4TB hard drive with its own power supply. This contains all my movies, TV and music.
I decided to manually upgrade to the latest version because for some reason the online updater stopped working and Sam told me my database was corrupted based on the logs I uploaded. I was previously using the November 2020 build.
I used the Windows updater, Vero booted and installed the November 2021 software.
Now, the white USB port has become effectively useless - no media will auto mount, not even a USB stick or any of my hard drives, powered or unpowered. My external HD will power up, spin, then the main light will go out but you can still hear slight motor i hum. It’s not broken or corrupted, it works fine in all my other computers.
I tried putting the device in the black USB port - it mounts! - but the remote control won’t work when in the white port so I can’t navigate. I figure it must be a power issue - maybe the newest software is faulty in that respect. I tried to revert to all the older versions of OSMC, going back one by one. When it tries to boot from USB with any version it now says “could not mount bootfs” - even though I just used this method to put the latest software on. Even if I try reinstalling the latest version this error message now appears. Is my USB port fried or something since installed the Nov 2021 build?

My Vero is now useless to me because I can’t get any devices to mount and I can’t revert to an older version of OSMC. I bitterly regret trying to update it, since it was functioning fine. I am disappointed that a software update recommended to me has broken the hardware.

Any suggestions before I have to buy another Vero (or look elsewhere)?


To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

Thanks for the reply. Here is the log URL:


Is the drive attached to white usb port, for these logs?

Thanks Tom.

It is yes, I plugged it in after the second boot and it did its attempt at spinning up.


For testing are you able to try another device (thumb drive, would be good), in the white usb port?

Thanks Tom.

For the moment I have achieved a temporary solution.

I plugged my external HD into the black USB port. I plugged the Vero remote USB receiver into one of the external HD’s own USB ports, and it works, so the white port isn’t needed. I can now use my Vero again with the remote, using the single black USB port. However, any guidance you can give as to why the white port isn’t operating would still be much appreciated.

Thanks again

Thumb drives also do not mount in the white port.


Is that with just a device in the white one and the black one empty?

Thanks Tom.

My standard setup was remote in black, harddrive in white. Whether the black has a device or not doesn’t affect whether the HD can mount in the white port.


Does a thumb drive mount if its the only device connected? Trying to work out if its a power issue.

Thanks Tom.

No, it still doesn’t.

There’s a known issue with a recent update causing issues with the white USB port not functioning. I’m still investigating this. Unfortunately I could not introduce a fix in time for the November update. The issue was introduced in August.

You could wait (I don’t have a solid ETA but it’s high priority); or install the 2020.11-1 version (based on Kodi v18.9) which will use an older kernel and not exhibit this issue.



1 Like

Out of curiosity Sam, are you saying that new units being shipped currently have only the black USB port functional? Before I reinstalled 2021-11-2 I had white port functionality with the same revision. It was updated successively from older 4.9 kernel test builds as updates were available. Very little info other than the hub being detected but hub doesn’t have any ports (err -19).

No - this is not the case.

The error you mention is probably a harmless message that is shown when the kernel tries to enumerate a non existent USB3 interface (we only
implement USB2).

This should now be fixed.

I’d appreciate it if you could test this and provide feedback before we potentially release this as an update to other users. To test this update:

  1. Login via the command line
  2. Run the following command to add the staging repository:
    echo 'deb buster-devel main' | sudo tee /etc/apt/sources.list.d/osmc-devel.list
  3. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  4. Your system should have have received the update.

Please see if the issue is resolved.

I also recommend you remove /etc/apt/sources.list.d/osmc-devel.list after updating.

I’d also recommend you deactivate the staging repository. You can do so with the following command:
sudo rm /etc/apt/sources.list.d/osmc-devel.list.

Please note that we will automatically disable this update channel after 14 days on your device in case you forget to do so to ensure that your system reverts to the stable update channel.

Thanks for your patience