Vero 4K USB->RJ45 adapter


I am experiencing some stuttering and missing sound when I play high bitrate 4K rips over LAN/WIFI. With iperf LAN the speed is 96, and on WIFI it’s 230. The average bitrate of the files I am playing is around 80. If I place them on a disk attached to the VEOR via USB everything plays fine. So I would like to connect a gigabit USB-RJ45 adapter to the VERO. Is there some well known adapters you know will work with the Vero ? I assume a Linux known adapter would be possible to install, but are there any pitfalls I should be aware of ?


You should be fine with build in Ethernet if you use fstab based smb or better nfs mounts and a respective buffer setting.

Generally no issues but I suggest to check if the chipset of the dongle you want to buy is present on the 4k

NFS worked perfect. Now I can watch 4K Atmos without any artifacts or missing sound, on both LAN and WIFI :slight_smile:

Thanks for helping me out :slight_smile:

Well, now I tried to watch John Wick, but the race scene in the start just has a too high bitrate, near 100 almost all the time, too much for my setup. I am thinking of increasing the buffer size in advancedsettings, how high can I set it, what is your recommandations ?Is there anything else I can tweak ? The share is NFS, the NAS is a freenas, it maxs out my gigabit network so I don’t think thats the problem.

The cache size in advancedsettings.xml can be set to 1 GB on a Vero4K but it won’t help if the bitrate of the video file is greater than the network can send. Realistically, a 512 MB cache will be more than sufficient for most situations.

If the wired interface isn’t fast enough, you could try wireless, which you say can reach 230 Mbps, but be aware that wireless is a less reliable medium and can be affected by radio interference.

I already set cache size to 512 MB, so that might not be the place to tweak. WIFI has less reliable performance than LAN, even with lesser bitrate movies. I think I’m back with the original plan, USB-Ethernet adapter. According to I have found two interestisng adapters. Linksys - USB3GIG v1 and TP-Link UE300. Which one to choose ? Price is similar, the TP-Link is slightly more expensive, but nothing that matters. Which one is best supported and gives me the highest stable speed ? My network boxes are Cisco firewall-router and Meraki APs.

I agree that’s probably the way forward. A quick search came across this article, where the author was getting around 300 Mbps on a Pi 3. I’d expect the Vero4K to equal or (probably) slightly exceed that figure.

I don’t have any personal experience of either device but both models seem to use the RTL8153 chipset, which is supported on OSMC, according to this post.

Thank’s that’s a very good article :slight_smile: I will purchase an adapter today and test over the weekend, and post my results here.

I have now tested with TRENDnet USB 3.0 Gigabit adapter, just plugged it in, no tweaking install or anything. I get speeds around 180 Mbit/sec. But it still skips frames, drops sound etc. I guess that has to do with the instability of gigabit? I then adjusted the line of sight from my AP to the Vero 4K, still speed is around 219 Mbit/sec, but now it plays flawlessly.

Is there something I can do to better the performance of the USB-Ethernet adapter? Install updated drivers or something? I don’t know how to do that on a linux box.


How did you test the speed? iperf3?

Yes I used iperfiperf

Try a larger TCP window size.


I’d recommend you use iperf3 (at both ends).

The original iperf has some weaknesses and shouldn’t normally be used.

Where and how do I change the TCP window size? I googled and found that /etc/sysctl.conf might be the place, but I added these settings and still got the same result and TCP window size.

net.ipv4.tcp_window_scaling = 1

net.ipv4.tcp_syncookies = 1

net.core.rmem_max = 16777216

net.core.wmem_max = 16777216

net.ipv4.tcp_rmem = 4096 87380 16777216

net.ipv4.tcp_wmem = 4096 65536 16777216

TCP window size is set as a parameter for iperf

Thanks, figured it out, here is the result from wifi.

That looks fast (and stable enough) to play back 4K HEVC content.


Yes, we managed to watch Transformers with only 2 times where it stuttered a little. Probably my AP that was a little unstable. I have now changed channel and moved it closer (1 mtr) to the Vero :slight_smile:
Thanks for all your help fzinken, sam_nazarko and dillthedog

1 Like