Vero 4K+ v19 - Many Problems

I am experiencing the same issues. Movie stops suddenly. If it is an episode, after the stopping in the middle of it the new episode starts. Lots of buffering, too. And then freeze, and I have to unplug Vero 4K+ and reboot.

Your sources in Kodi are smb://[name] and I’m talking about changing that to smb://[IP address] to avoid name resolution issues.

When you upload logs via My OSMC you choose which logs get uploaded. You only selected the Kodi log.

With all due respect you don’t know if your experiencing the same issue as we don’t yet know what the OP’s issue is. You have not provided logs or details enough for anyone to even venture a guess of what may be going on with your setup. Your description also sounds very different from the OP to me. I would suggest to start a new thread with logs and relevant detail and description to maximize the possibility that someone may be able to asset you.

Here is a full log


In this session I used Estuary and the scanning issue still persists. I was also unable to add a new data source in videos / files / _new. This message comes up:

“Error 2 Share Not Available”
“Couldn’t Connect to Server”

Updating to v19 was the biggest mistake I could have made. Please help.

You still have the lookup issue.

2021-08-11 22:49:10.850 T:2687    ERROR <general>: Unable to lookup host: 'DNS-343-SOURCE'
2021-08-11 22:49:10.894 T:2686    ERROR <general>: Unable to lookup host: 'DNS-345-SOURCE1'

Suggest to switch to IP based sources otherwise need to install nmblookup

sudo apt-get install samba-common-bin

I see your UI is set to 4K and not 1080p as I suggested. This will cause numerous issues including a choppy interface. Please reference the following…

Recommended display settings

We recommend people with 4K TV’s set their user interface (UI) to 1080p. Kodi’s UI is not optimized for 4K yet and this can put unnecessary demands on your device and can lead to a suboptimal picture quality, as well as potentially cause other issues.

The settings we recommend are as follows…

Settings>System>Display>Resolution> 1920x1080p
Settings>System>Display>Whitelist> (empty) *
Settings>Player>Videos>Adjust display refresh rate> On start/stop

Some televisions may also need, or benefit from, the following being set…

System>Display>Force 4:2:2 colour subsampling> (enable)

With the above settings your UI will be output in Full HD and your 4K content will be output in 4K. *Information regarding the whitelist can be found here. If you have any doubt, feel free to upload some logs so we can verify that your settings are indeed correct.

In settings>media>videos>use video tags you should disable that option as it is much more likely to make some items fail to scan than provide any useful function.

In add-on go to information providers and check to see if TVDB is installed, enabled, and current (should be 3.2.8). I would suggest to consider switching over the TMDb TV Shows instead. To do that you would go to video>files and on each TV show source context menu and select “change content”.

As for the DNS issue I would repeat my earlier advice to try to bypass that.

I switched source paths to IP and UPDATE LIBRARY now reconciles (although it still takes longer than it used to). After this switch, I haven’t had an opportunity to use Vero long enough to verify whether this fixes the UI/playback issues, but I suspect it will… I’ll report back after I have a chance to test further.

What I don’t understand is why after 3 years, the unit all of a sudden cannot reconcile the data sources via path name immediately after installing v19. Something changed in the Vero 4k+ that caused this to happen. My LAN configuration has remained unchanged for years.

The Vero is always set to 1080p… I’ve been toggling the resolution between 1080p and 4K to test the performance delta between the two settings. The resolution happened to still be at 4K when I generated the log file. I will definitely also apply your recommended video settings to see if that further improves things.

EDIT: I just noticed that when I set the resolution to 1920x1080p, the OS does not fit the screen. Text near the edge (e.g. clock) falls off the side. I don’t recall ever seeing this on 1080p. Recommendations to fix this?

Other than polling for cast images, all metadata is stored locally in directory-specific .nfos.

Thanks for your help… Again, I’ll report back once I have a chance to properly test everything with this new configuration.

Well nmblookup was never really favoured but it could surely be a change in the recent update that disabled it.

Yes, configure you TV correctly, normally function is called just scan, 1:1,… if you let us know your TV Brand and Make we can let you know.

I think this specific issue self-corrected. All I had to do was change the TV source and switch back and the TV adjusted for the resolution change. Thx again.

It looks like everything is working as it should. Thanks for your help.

If at all possible I would like to go back to browsing for an SMB path rather than manually entering an IP address + path. My LAN has multiple NAS, each with multiple HDDs, which adds up a fair number of unique data sources that need to be entered into Kodi. Browsing for a path is so much easier, especially when incidents like this come up.

Just add each NAS as a network path and then you can add all the sources after that without typing anything in. See this thread that I’d just gone over this in plenty of detail…

So my Vero 4K+ works perfectly fine except for one issue. Since upgrading to v19.1 and changing the network locations to IP addresses, the unit has a delay of ~22 to 25 seconds from the time I press play on a video before it actually starts playing. This recurs 100% of the time a video is started or resumed.

I should note that the NAS HDDs the Vero 4K+ are reading from are awake and spinning (i.e. the delay is not caused by the HDD spinning-up). Before upgrading to v19.1 and before remapping with IP address, the delay was approximately 4 seconds.

Debug enabled logs might tell where the delay come from

Here is the log file. For the log file I tried starting 3 different videos on different data sources and each one had a delay of well over 20 seconds.

** Link removed **

Before upgrading to v19 and changing data sources to IP videos played instantly and had a delay of ~4 seconds if the source HDD was sleeping and had to spin up.

Not much info what happens in that 20 seconds but have you tried with the OSMC skin if you have the same delay?

2021-08-20 22:58:37.345 T:2642    DEBUG <general>: HandleKey: return (0xf00d) pressed, action is Select
2021-08-20 22:58:37.345 T:2943    DEBUG <general>: Thread Timer 3551006928 terminating
2021-08-20 22:58:37.346 T:2642    DEBUG <general>: ------ Window Deinit (DialogVideoInfo.xml) ------
2021-08-20 22:58:46.576 T:2707    DEBUG <general>: [ script.embuary.helper ] Force widgets to refresh (VideoLibrary.OnUpdate)
2021-08-20 22:58:46.577 T:2707    DEBUG <general>: [ script.embuary.helper ] Execute: AlarmClock(WidgetRefresh,SetProperty(EmbuaryWidgetUpdate,20210821025846,home),00:10,silent)
2021-08-20 22:58:56.001 T:2642    DEBUG <general>: CPlayerCoreFactory::GetPlayers(smb://

I’ve been using Confluence for years with no issues until updating to v19.1 and changing paths to IP address. I tried Confluence, Embuary, and one other and the delay is identical (> 20 seconds).

I don’t know what else to do.

Use OSMC Skin and upload new logs to show the issue

Here you go… (updated log)

@fzinken thanks for your help… Also can you please remove the log link url you copied on your earlier reply to me? I don’t like that personal info floating around. Thx

  1. It might just be a coincidence, but the log shows that connman took over 30 seconds to confirm the presence of an Internet connection. It could be a problem with the LAN, WAN or DNS, but I’d normally expect to see it taking 1 or 2 seconds:

    Aug 21 13:14:49 OSMC connmand[2358]: eth0 {add} route gw scope 0 <UNIVERSE>
    Aug 21 13:15:21 OSMC connmand[2358]: eth0 {del} route gw scope 0 <UNIVERSE>
  2. It took almost 10 seconds to check for the existence of a subtitle file on the server.

    2021-08-21 13:18:46.479 T:2836    DEBUG <general>: ScanForExternalSubtitles: Searching for subtitles...
    2021-08-21 13:18:46.560 T:2564    DEBUG <general>: ------ Window Init (DialogBusy.xml) ------
    2021-08-21 13:18:53.832 T:2837    DEBUG <general>: Thread BackgroundLoader 3938123984 terminating
    2021-08-21 13:18:56.262 T:2836     INFO <general>: ScanPathsForAssociatedItems: found associated file smb://
    2021-08-21 13:18:56.262 T:2836    DEBUG <general>: ScanForExternalSubtitles: END (total time: 9779 ms)

It could be network- or server-related or, at a stretch, a very inefficient search algorithm. Have you checked the network performance to/from the server, using iperf3?

Edit: One other thing. The log is also showing that network flow control is switched on. If true, this can potentially cause networking problems.

Aug 21 13:14:49 OSMC kernel: meson6-dwmac c9410000.ethernet eth0: Link is Up - 1Gbps/Full - flow control rx/tx