Vero 4k video freeze for 3-5 seconds on last frame after a pause that was longer than 10 seconds

#41

Just tried this. No change.

#42

Going to upload some logs now. Shall I PM them?

#44

Just here, please.

#45

Will PM you since it’s everything. Incoming PM!

#47

Just to say i also experienced these exact same symptoms for the first time over the weekend with a uhd bluray rip that i’ve watched numeruous times; without any previous problems. After it happened, i hit stop then play to get things going again and all was fine. Also paused a couple more times thereafter, for a minute or so each time without issue; so might not be so easy to reproduce. Unfortunately did not have debugging enabled when this occured.

split this topic #48

4 posts were split to a new topic: Video Freeze when using Kodi Alpha V19

#49

I actually use Start/Stop, so this can‘t be it. I also tried every other setting possible. And as some people mentioned, it also happens on a clean install of osmc.

#50

It won‘t happen on every file. You can go five 1080p movies and not have it… or you have it on three movies in a row. But once you do have it with a file, you will always be able to reproduce the issue on that file.

And you don‘t need to pause it for hours. I either happens after 10 seconds of pause or it won‘t happen at all. Something happens after 10 seconds of pause.

#51

Yes this seems to be all about the video driver. If you google this phenomenon related to Kodi, it was always a video driver issue in the past.

I spent hours googling the issue and I came across threads on various forums dating back to 2011… and it always came down to video driver issues… and more concerning, half of the threads were amlogic related… someone even posted a solution with some sort of script but I can‘t find that thread again.

#52

All I can say is it’s been annoying the crap out of me lately. Any devs with any further input on this?

#53

This is definitely a very hard to track down issue. I personally have not been able to reproduce it. And believe me, I have tried. I’ve paused videos time and time again, as long as 8 hours and they always just start again (for long pauses it takes time for the drive to wake up for the video to start).

Don’t take this as we don’t believe you, we do. It’s just trying to reliably reproduce it.

#54

Do you have any remuxes? It basically does it with any of mine. Some lower res movies it won’t, but e.g. every episode of Game of Thrones season 1 and 2 remux (that I’ve checked) experience the issue.

This issue is so easily reproducible I find it staggering it’s not reported more.

#55

Like I edited above, it happens exactly after 10 seconds of pausing. If it does not happen after 10 seconds, then it won‘t happen. If you unpause it before 10 seconds have past, video resumes without issues.

All I can say is that from my observation, the likelyhood of this happening is greatly increased the higher the quality of a file. It is nearly a guarantee for me on blu ray remuxes (untouched blu ray rips just remuxed into mkv), which usually are around 30gb.

#56

Everything said here is absolutely true, and my findings exactly.

#57

I provided logs yesterday but haven’t heard anything yet.

#58

I have a large mix of remux and full rips. I simply cannot reproduce it with either. I have over 1000 movies (SD, HD and UHD), TV Shows (15000+ episodes) and Music VIdeos (750). I just can’t reproduce the problem.

And from my observations, all of my BD rips (made with MakeMVK) do not have this problem. They are not remuxes, but direct rips from BDs and UHDs. (some are 60GB+ in size)

#59

I don’t know what to say then, except hopefully someone checks out my logs.

1 Like
#60

I mean it is not like we are idiots. WilliamG, myself and others here are veterans and know what we are talking about. The issue is very frustrating and I have spent many many hours now to get it solved myself. Absolutely nothing, no settings no reinstall whatsoever will solve it, it has to be something completely out of the control of the user.

I could send you a file, maybe I cut one of my remuxes into a smaller sample… but I can do that not before todays afternoon. But really most of the files affected are just remuxes of bluray rips (makemkv) with the main file putinto the mkv container using mkvtoolnix.

#61

Indeed, there are two sets of logs now. I don‘t know if I did everything right with my logs in the starting post, I hope so.

Just read what we are writing. Pausing a video for 8 hours for example was totally unnecassary and a waste of time because it happens after 10 secs or not.

#62

I did not say isn’t not happening. I said that it is difficult to reproduce.

If you are using MakeMKV, why are you using mkvtoolnix? When I rip with MakeMKV, I just rip the main title. No extra processing.