Vero 4k video freeze for 3-5 seconds on last frame after a pause that was longer than 10 seconds

#1

I think this is a new experience for me after the Kodi 18 update:

On some h264 files the video freezes for 3-5 seconds after a pause. Only happens when the pause was longer than 10 seconds. I tried dozens and dozens of files (mostly 1080p blu ray rips or remuxes), some experience this behavior, some not. Never ever had it before the Kodi 18 update. Streamed via LAN from a Synology NAS, buffer is full and I guess that is no problem.

The audio will immediately continue, just the video is stuck on the frame before I paused. It recovers after mentioned 3-5 seconds but it is super annoying. Also sometimes the video player gets stuck on the last frame on fast forward/rewind, but that is rather rare and I could not find any logic of how and when that happens.

No idea if it is related to the phenomena that was mentioned on live TV. The one thing that is odd that it happens only after a pause of more than 10 seconds, If I pause and unpause in less seconds, the video player will not freeze on last frame. Weird stuff.

Googling this brought me to threads 7-8 old on Kodi forums, but nothing of late.

Anyone else having the issue or is the issue known to the team or any relation to the live stream frame freeze?

#2

Can you post a debug log? I think I know what this is but want to verify.

Sam

#3

https://paste.osmc.tv/ceduqajaxi

I was continuing the movie I ripped from a bluray (unthinkable.2010.1080p.DL.mkv), then I paused longer than 10 seconds (result: freeze), then a shorter pause (result: no issues, no freeze) and then again a longer pause (result: freeze)… just to confirm what I had described above.

The file is an untouched blu ray remux, so it surely is not a problem with the encode. I have many other files with the same behavior now.

#4

For what its worth, the issue does not appear to exist if I disable hardware decoding… but that obviously not a solution… I stumbled upon that in a very old thread on the official kodi forum and it was about those (older) amlogic SoCs. No idea why that creeped into my poor Vero 4k but Inreally like to get rid of it :smiley:

#5

I’ll get this solved, don’t worry.

#7

Thx Sam :slight_smile:

I guess there is nothing, no setting I can do to get this solved? I really tried everything.

#8

I don’t think it’s related to settings.

Sam

#9

Happens on x265/HDR as well.

#10

Thanks, Sam. Just want to register that I’m having the same issue. Would also like to note that in my experience the behavior is not entirely consistent and seems related to bitrate. On high bitrate files I’m able to reproduce the issue consistently. On low bitrate files it manifests more as a slight but noticeable hiccup than a freeze. It’s almost as if after pausing for a certain length of time, some aspect of the video rendering goes to sleep, and the time it takes for it to wake back up depends on the bitrate, if that makes sense?

#11

I can confirm that the higher the bitrate, the more likely it is going to happen. That is why it is almost guaranteed to happen on untouched bluray remuxes, which of course have a very high bitrate. Doesn’t happen much or at all on tv series, which are usually lower bitrate. But on high bitrate stuff, it is almost guaranteed to happen.

Can confirm all other observations from whahaa as well.

#12

I’m affected too. Have only seen it on 4K remuxes on my setup thus far but still quite irritating.

#13

I think everyone is affected, it is just that it requires a longer pause (10+ seconds) and a high bitrate file to happen. But it really is a big problem for me because I watch high bitrate movies plus I use subtitles search (auto pause when doing that, disabling auto pause is equally bad as the freeze) on most files and it takes more than 10 seconds to find and download the ideal subtitle.

Is there any progress on the issue? I hope it is easily identified by the OSMc team as „something“ happens exactly after 10 seconds of pause.

#14

I haven’t reproduced it just yet.

Sam

#15

Just use a high bitrate file, like a blu ray remux or a 4K encode or remux. I provided a log too in the third post.

#16

I have now also noticed it in a couple of fairly regular 1080p rips (not remuxes) so neither with high bitrates, but the behaviour was different in each. On one there was just a brief stutter on resume and the other a VERY long (10secs or so) picture freeze (with the sound continuing) until it sorted itself out, over double the freeze time compared to the 4K remuxes I’ve tried. I’m not convinced it’s bitrate related…

#17

It seems a bit random on most files but the chance seems to skyrocket with the bitrate. But you are right, it can happen on „normal“ files as well.

And yes, there is always a small stutter after every pause but that is less of a problem than having the video frozen for 5 seconds while the movie continues with audio.

Either way, those video freezes are a huge problem and I hope a solution comes quickly.

#18

Same issue here. The video remains paused after hitting Pause and then Play, but the sound continues. Pressing “quick rewind” gets the video to play normally again, but obviously that’s not a great solution.

I am playing MKV files from an portable USB hard drive.

#19

There is even an addon to do an auto jumpback after pause:

https://kodi.wiki/view/Add-on:Unpause_Jumpback

Could not to get it work though in a satisfying matter. Actually it makes everything even worse.

I just hope Sam can fix it soon.

#20

I’m looking in to this. Give me a day or so.

#21

Glad I ran across this thread. I believe I’m experiencing the same thing as well but my Vero 4K+ is so new it never ran anything prior to 18.2 so I was wondering if the hardware was bad.

Anyway, in my cases I’m using PlexKodiConnect and so every file I play is being streamed over an HTTPS connection. I see the video paused on a single frame while the audio plays, then after a few seconds the video plays at around double the rate and eventually catches up to the audio and they resync. I see this on resume from a long pauses and sometimes on playback start. It’s usually on the order of less than once a day I see it. Most of the time I’m playing files that are only 720p so it doesn’t require really high bitrate to produce it.

I have this in my advancesettings and I know it’s not a buffer underun:

<advancedsettings>
  <cache>
    <buffermode>1</buffermode>
    <memorysize>524288000</memorysize>
    <readfactor>20</readfactor>
  </cache>

At first I thought it was swapping due to my large cache size but it has never swapped

% cat /proc/vmstat|grep pgpg
pgpgin 0
pgpgout 0

I’m fairly certain every case where I’ve seen this I was using a passthrough audio if that means anything.

Anyway, looking forward to the resolution.