Vero 4k will not boot up

I got a Vero4k in December '17 and started using it in May this year as the DVB-T2 issue was resolved. I use the Vero4k with an OSMC USB hub that has 2 DVB-T2 tuners attached. The package has been working fine all summer, but today I noticed that the Vero4k had shut down and the blue lights on the USB hub where flashing. As soon as I detached the Vero4k the flashing stopped. I tried to startup the Vero4k with just HDMI and power connected, but nothing happened, just the red light at the front light-up. I’ve also tried starting the Vero4k with an SD card with the 2018-7 image and nothing happens. Same thing if I extract the image to a USB stick, nothing.
Any suggestions how I could get the Vero4k working again?

If even the toothpick recovery method fails (did you tried) it might be a power supply issue. If that is the case you can contact @sam_nazarko at with your order number.

Where do I find the reset button?

Explained in the wiki

Find a non-conductive pin, such as a toothpick. Put it in the round port nearest the HDMI port. You should hear a soft, audible click

If you see blue LED on Vero 4K turning RED, then I’m fairly certain it’s the Vero 4K PSU. Sometimes PSUs just wear out (I think it’s the electrolytic capacitor stops holding its charge).

Replace the PSU, and you should be fine again.

You can contact for a replacement PSU.