Vero 4K+ with Synology NAS - How to connect?

I thought NFS was the best option?
@Rossi is now using SMB. What is better?

If your connection is fast enough then neither is really “better” as they would both perform the same job fully. Depending on the situation you can get increased performance from NFS due to it having lower overhead vs. Samba and being a native Linux protocol. However, if you not playing something that requires more bandwidth than your connection allows then this extra speed has little benefit to provide.

Thanks. Then I’ll try NFS. If there are problems I switch to SMB.

Bastian, I have a older Synology DS214Play with my V4K+. I was using a WD TV Live for the longest time but it could not handle 4K. There was some setup in Synology so the V4K+ could see the media. Use static IPs and a good patch cables.

Using NFS on my Synology without issue.

I use NFS on my DS218+ as well, together with FSTAB mounts.
Never looked back.
It takes some effort to setup, but always works and is lightning fast when needed.
Here’s a good read on FSTAB : FSTAB
When right clicking your shared folder with all your content, choose the NFS-permissions tab.
In there you need to point to the specific IP-address from your 4K, otherwise it won’t work.

you don’t need the actual IP address of the V4K, you can use “*” or define a range for your network, e.g.

image

I have the “non-privileged ports enabled” since I recently added a Shield to my collection of streaming devices, and found that Kodi running on the Shield could not access the NFS shares without this, it’s not needed for my OSMC and LE devices.

1 Like

Yep got firestick, popcornhour devices etc and have the iP wildcard settings 192.168.0.* so any local device can access.
Still able to give just read access for devices that are kids etc. So only Vero4k can read/write to NAS.

Hi All,

I have a Synology - Vero4k+ NFS issue: 1 folder from the 3 is inaccessible after mounting via GIU (but accessible via command line).

Details:
Shares on the Synology NAS:
bash-4.3# exportfs -v
/volume2/Music (ro,async,crossmnt,insecure,no_root_squash,no_subtree_check,insecure_locks,anonuid=1025,anongid=100,sec=sys,ro,no_root_squash,no_all_squash)
/volume2/Photo (ro,async,no_root_squash,no_subtree_check,insecure_locks,anonuid=1025,anongid=100,sec=sys,ro,no_root_squash,no_all_squash)
/volume2/Movie (ro,async,no_root_squash,no_subtree_check,insecure_locks,anonuid=1025,anongid=100,sec=sys,ro,no_root_squash,no_all_squash)
bash-4.3#

(Hint: Music and Video are totally identical)

Fstab on Vero:
root@osmc:/mnt# cat /etc/fstab
rootfs is not mounted in fstab as we do it via initramfs. Uncomment for remount (slower boot)
#/dev/vero-nand/root / ext4 defaults,noatime 0 0
192.168.2.2:/volume2/Music /mnt/SynologyMusic nfs ro,noauto,x-systemd.automount 0 0
192.168.2.2:/volume2/Movie /mnt/SynologyMovie nfs ro,noauto,x-systemd.automount 0 0
192.168.2.2:/volume2/Photo /mnt/SynologyPhoto nfs ro,noauto,x-systemd.automount 0 0
root@osmc:/mnt#

Relevant output of mount on Vero:
192.168.2.2:/volume2/Photo on /mnt/SynologyPhoto type nfs4 (ro,relatime,vers=4.1,rsize=131072,wsize=131072,namlen=255,hard,proto=tcp,port=0,timeo=600,retrans=2,sec=sys,clientaddr=192.168.10.159,local_lock=none,addr=192.168.2.2)
192.168.2.2:/volume2/Music on /mnt/SynologyMusic type nfs4 (ro,relatime,vers=4.1,rsize=131072,wsize=131072,namlen=255,hard,proto=tcp,port=0,timeo=600,retrans=2,sec=sys,clientaddr=192.168.10.159,local_lock=none,addr=192.168.2.2)
192.168.2.2:/volume2/Movie on /mnt/SynologyMovie type nfs4 (ro,relatime,vers=4.1,rsize=131072,wsize=131072,namlen=255,hard,proto=tcp,port=0,timeo=600,retrans=2,sec=sys,clientaddr=192.168.10.159,local_lock=none,addr=192.168.2.2)
root@osmc:/mnt#

(Hint: All are totally identical)

permissions of /mnt:
root@osmc:/mnt# ls -l
total 0
drwxrwxrwx 1 root root 98 Jan 1 17:15 SynologyMovie
drwxrwxrwx 1 root root 306 Dec 23 20:17 SynologyMusic
drwxrwxrwx 1 root root 168 Dec 23 19:33 SynologyPhoto
root@osmc:/mnt#

Issue:
If I navigate in KODI to Movie --> Add Videos --> Browse --> Root filesystem --> mnt I cant enter to the SynologyMovie directory, however the two other (SynologyMusic and SynologyPhoto) is accessible, and I see the content.

Debug log:
2021-01-08 10:26:36.384 T:4067827728 ERROR: GetDirectory - Error getting /mnt/SynologyMovie/
2021-01-08 10:26:36.385 T:4067827728 ERROR: CGUIDialogFileBrowser::GetDirectory(/mnt/SynologyMovie/) failed

If I use command line (Midnight Commander) all the three folder is accessible, and the content is there.

What I realised: If I press the Enter button in KODI to enter to SynologyMovie folder, it lost all access rights suddenly, but after cca a minute is has full access again:
root@osmc:/mnt# ls -l
total 0
d--------- 1 root root 98 Jan 1 17:15 SynologyMovie
drwxrwxrwx 1 root root 306 Dec 23 20:17 SynologyMusic
drwxrwxrwx 1 root root 168 Dec 23 19:33 SynologyPhoto
root@osmc:/mnt#

Could you please help me how to fix this and make available my movie files?

The directory may not be accessible if it’s mounted as root and the osmc user cannot access it. Does ls work as a non-privileged user?

No, doesn’t work for SynologyMovie, but works for the other 2 which are mounted on the same way.

osmc@osmc:~$ ls -l /mnt/
total 0
d--------- 1 root root 98 Jan 1 17:15 SynologyMovie
drwxrwxrwx 1 root root 306 Dec 23 20:17 SynologyMusic
drwxrwxrwx 1 root root 168 Dec 23 19:33 SynologyPhoto
osmc@osmc:~$

And the Synology guest user may read/write to the shared folder SynologyMovie?

Example:

Since you set squash “map all users to guest”, the Syno guest at least need to have access to the shared folder.

I checked, guest has ‘No access’ for Movie, Music and Photo. I’ve granted read access to Guest for /volume2/Movie, but still not able to access from OSMC, however the /volume2/Music and /volume2/Photo are accessable from the OSMC.

I realised some interesting things on my Synology (some irrelevant lines are removed):
bash-4.3# ls -l /volume2/
total 0
d---------+ 1 root root 98 Jan 1 17:15 Movie
drwxrwxrwx 1 root root 306 Dec 23 20:17 Music
drwxrwxrwx 1 root root 168 Dec 23 19:33 Photo
bash-4.3#

Shared folder ‘Movie’ has different OS level rights than Music and Photo. Could be this the issue?

Try setting guest to allow read/write to the relevant share. I’ve had issues with read-only.

I did it. On OSMC I’ve umounted then mounted the share, but still no access.
On LibreElec / RaspBerry I have no issues, the share is accessible. Really strange, and I doubt that the issue is on server side, but I’m not a Linux expert.
the Photo and Music share is also accessible under Kodi.

Can you post s screenshot of your Synology NFS rule for the share?

My first hour of Vero ownership was frustrating for similar reasons, my LE Pi’s connected to NFS shares without issue, my Vero would not. I had to change the “squash” rule. There are a few that will work (eg map all to admin, or to guest if guest is configured correctly), but the default I had for my LE Pi did not work for the Vero. My current config, posted above, works with everything, but guest has write access to the video share.

Sorry guys, missread @ac16161’s screenshot to be posted by @brathes.

For initial testing, would it help to set your Syno squash rule to map all users to admin, as that should bypass any issues with the guest account?

From the same IP address?
Using the same fstab?

On OSMC what is the output of showmount -e 192.168.2.2 ?

This solved the issue. Now I can reach my /volume2/Movie folder.
Is this a right setup or should I need troubleshoot further?