Vero 4K+ with Synology NAS - How to connect?

The directory may not be accessible if it’s mounted as root and the osmc user cannot access it. Does ls work as a non-privileged user?

No, doesn’t work for SynologyMovie, but works for the other 2 which are mounted on the same way.

osmc@osmc:~$ ls -l /mnt/
total 0
d--------- 1 root root 98 Jan 1 17:15 SynologyMovie
drwxrwxrwx 1 root root 306 Dec 23 20:17 SynologyMusic
drwxrwxrwx 1 root root 168 Dec 23 19:33 SynologyPhoto

And the Synology guest user may read/write to the shared folder SynologyMovie?


Since you set squash “map all users to guest”, the Syno guest at least need to have access to the shared folder.

I checked, guest has ‘No access’ for Movie, Music and Photo. I’ve granted read access to Guest for /volume2/Movie, but still not able to access from OSMC, however the /volume2/Music and /volume2/Photo are accessable from the OSMC.

I realised some interesting things on my Synology (some irrelevant lines are removed):
bash-4.3# ls -l /volume2/
total 0
d---------+ 1 root root 98 Jan 1 17:15 Movie
drwxrwxrwx 1 root root 306 Dec 23 20:17 Music
drwxrwxrwx 1 root root 168 Dec 23 19:33 Photo

Shared folder ‘Movie’ has different OS level rights than Music and Photo. Could be this the issue?

Try setting guest to allow read/write to the relevant share. I’ve had issues with read-only.

I did it. On OSMC I’ve umounted then mounted the share, but still no access.
On LibreElec / RaspBerry I have no issues, the share is accessible. Really strange, and I doubt that the issue is on server side, but I’m not a Linux expert.
the Photo and Music share is also accessible under Kodi.

Can you post s screenshot of your Synology NFS rule for the share?

My first hour of Vero ownership was frustrating for similar reasons, my LE Pi’s connected to NFS shares without issue, my Vero would not. I had to change the “squash” rule. There are a few that will work (eg map all to admin, or to guest if guest is configured correctly), but the default I had for my LE Pi did not work for the Vero. My current config, posted above, works with everything, but guest has write access to the video share.

Sorry guys, missread @ac16161’s screenshot to be posted by @brathes.

For initial testing, would it help to set your Syno squash rule to map all users to admin, as that should bypass any issues with the guest account?

From the same IP address?
Using the same fstab?

On OSMC what is the output of showmount -e ?

This solved the issue. Now I can reach my /volume2/Movie folder.
Is this a right setup or should I need troubleshoot further?

No, from the same IP range (no IP restriction is set on server)
No, using Kodi NFS

osmc@osmc:/$ showmount -e
Export list for
/volume2/Movie *
/volume2/Photo *
/volume2/Music *

Great to hear you are up and running. This is how I ran my setup for a while. I decided (without any knowledge of actual security benefit) that setting the squash rule down to the guest account could not do any harm. For this to work, the guest account needs relevant privileges for the shares that Kodi will access.

I went down to ‘Guest’ account, and working fine, thank you all!

Tonight I connected my Vero 4K to the Synology NAS.
My path is: / mnt / 03_Musik nfs noauto, x-systemd.automount 0 0

On my Synology I have the parent folder / volume1 / Video_1.
Below that are the individual folders that I want to access.
02_Movies 3D

Did I use the correct path to directly access the 03_Musik folder?

Which path do I have to enter in Kodi in order to be able to access the 03_Musik folder directly?

Or should I generally create a new folder structure. e.g.

/ volume1 / Movies
/ volume1 / Movies_3D
/ volume1 / music

There is a preformat option </> that you can use to keep from mangling your paths (at least I hope that is why they look like that).

You are mounting video_1 to /mnt/03_Musik so that would show that list of folders, not the contents of the 03_Music folder if that is what your asking. You don’t need to make different shares for each file type. All you need is a single share with all your media in it that is mounted and then in Kodi you would setup your sources to their respective paths.

For example if you mounted to mnt/video_1 then you would add sources for

/mnt/Video_1/02_Movies 3D

and in the Music section add


1 Like

Many Thanks. I will try tonight.

My path should then look like this? / mnt / Video_1 nfs noauto, x-systemd.automount 0 0

You have inserted spaces where they shouldn’t be. It should be like this… /mnt/Video_1 nfs noauto,x-systemd.automount 0 0

It is spelled out fairly clear in this thread…

Thank you very much, it worked.

Now I just have to decide whether I want to put concerts under films or music videos in Kodi :blush: