Vero 4K won't boot from install media

A few days ago, one of my two Veros went into a “Please Stand By” boot loop. Went to one of my Windows machines and downloaded the installer and using it created both a USB install stick and a microSD install device.

The Vero 4K ignores each of them on power up.

Is there a “secret key” that I have to press on the connected USB keyboard while powering up to force the Vero to boot from the install media rather than the (evidently trashed) internal storage?

Thank you!

Please show a screenshot of the contents of the USB/SD card.

Flash drive:

microSD card:

You could rename ‘kernel.img’ to ‘recovery.img’ and use the toothpick method to force the device to boot from external storage.

Thank you, Sam, will give that a shot and report back.

Still no go, but more info.

Renamed kernel.img to recovery.img first on the microSD card, pressed the reset button and held it, applying power and counting to 30 before releasing the button.

Exact same behavior as when not pressing the reset button at all (see BEHAVIOR below for more details).

Renamed kernel.img to recovery.img next on the flash drive and followed the same “toothpick method” as with the microSD card; same behavior. BUT because I used a flash drive with an LED that flashes on i/o, there was more visual feed back as to what is going on.

BEHAVIOR [yes, I’m in the States]: The boot cycle is as follows – “Please stand by” message displays for three seconds and during this three seconds the flash drive LED flashes as the Vero tries to (presumably) read from it. This is followed by four seconds of a black screen, during which the ‘+’ LED on the Vero illuminates for the first second. Then the cycle repeats.

At any rate, having the reset button depressed makes no difference at all in the behavior, whether the microSD card, the flash drive or neither is inserted, the behavior is the same.

Any other ideas, or is it bricked?

Thanks, Sam!

Do you have a USB-A cable?
You could plug the device in to a PC (connect USB cable to white port) and see if it is detected.


Sam, on a Windows machine, Windows acknowledges that it is connected, but what should I expect to see? It doesn’t recognize it as a mass storage device, and in fact doesn’t show up as something that can be disconnected or ejected.

Should I have the power supply connected while I’m trying this?

Thank you.

What’s it show up as in Device Manager?

No need

As far as I can tell, it doesn’t show up at all in Device Mangler, maybe you’ll see it since I don’t know what I’m looking for:

What is the native file system on the internal storage? Maybe I’ll try connecting it via USB to a linux machine (daily driver) and see if I can mount it.

FWIW, when connected to a linux machine it doesn’t show up as a block device, so still no access to the internal storage.

Let me know if the screenshot of Device Mangler tell you anything, Sam, and TIA.

On a Linux machine, try run lsusb.

Yeah, the Vero doesn’t show up, Sam.

If you hold the toothpick in with no installation media attached, does it appear?


If this is the Vero, then yes, it does.

If this ISN’T the Vero, then I’m a little worried because I don’t know what it is or where it came from and why it wasn’t appearing before. :slight_smile:

But that is a different issue. :slight_smile:

That is the Vero, yes.

I’ve sent you a PM with some instructions. You’ll need a Windows PC.

Wanted to add the end of the story.

Sam spent quite a bit of time providing instructions for flashing the boot ROM and a bunch of other stuff to revive my Vero 4K but we never could get it to boot from either USB or micro-SD, so after getting an RMA from Support, I shipped it back to him to see if anything could be done to revive it, even though it was long since out of warranty.

Sam was able to identify a hardware problem but had difficulty sourcing a replacement part needed to fix the issue and I had another Vero 4K that was doing fine, so the need for the problem unit wasn’t urgent.

Sam notified me yesterday that he has repaired the player and shipped it back to me. He asked me to pay for the return shipping which was completely reasonable considering that the unit was out of warranty.

The support experience was altogether professional, reasonable and very satisfying to me.

Thank you, Sam! I look forward to hooking the unit back up to my 75" display!


Truly a wholesome story.

It is so satisfying to see that at this age of razor-thin margins and massive volumes with non-existent support, fly-by-night vendors and everything electronic just thrown to garbage instead of repaired, if not even planned obsolescence, there are still vendors that make a quality product and stand by it.

The contrast to the various Android based device vendors is glaring. Once again, bravo to team OSMC.