Vero 4k+ won't boot, tried to reinstall with multiple devices and using the toothpick method

Hello everyone,

I’ve been trying to resuscitate my Vero 4k+ which I discovered was no longer booting one day. I’ve been trying the different suggestions on how to do a reinstall, using multiple different USB keys and SD cards with no luck. I’ve also tried the previously successful “toothpick” method, and still no luck. I’ve even purchased a USB A-to-A cable to validate that the power supply wasn’t the source of the problem, still no luck.

If I plug the device into a Windows machine, it is detected, so from what I’ve read, this means that it should still be alive, just not functioning anymore.

When plugged into any power source, the red light just flashes briefly, then nothing. I’ve try both a monitor and my TV (neither of which have changed) and the result is still the same.

I’ve read some comments about the eMMC being corrupt, and a procedure being available to recover from this. Is this worth a try after everything else attempted?

Thanks!

Have you checked if the Vero might show up on your network if you wait some time? That would indicate that there is a HDMI problem but OS fine.

Thank you for such a fast answer. I’ve checked, no, an IP is never assigned to the device, nor is the device detected as being plugged into the port. Link goes up, but it doesn’t seem as though there is an OS behind it.

Also, I’ve just confirmed that the original power supply is indeed dead, as when I tried to use it again (just to see), the optical connector light doesn’t even turn on, whereas with the USB A-to-A cable, the optical connector light remains on.

Ok, guess @sam_nazarko might have a better idea to judge if emmc corrupt or other issue

Did you try a replacement power supply, or only a USB-A cable?

Hello Sam,

I don’t have a suitable replacement power supply, which is why I purchased a USB A cable instead. I’ve ensured that I’m using a 5V 2A power supply for the USB A cable, as well as having tried directly attached to a computer.

Sorry for the late follow up on this one – I’ll send some instructions shortly.

Sam

Not a problem, and thanks in advance!

I’ve sent you some instructions via PM.

Hi Sam,

Sorry for the delayed reply, I’ve only just been able to try your instructions. I think that my Vero 4k+ was not up to date when it tanked, as I’m getting these errors when trying to flash the recovery image:

Any suggestions now? Do you have an older image I can try? Or is this a more serious hardware problem?

Thanks,

Ashley

That doesn’t look good. Can you make sure the cable is well connected and show me the checkboxes on the side?

I’ve retried again, and have tried both USB ports on the computer, same results. Here’s a full screenshot with all the settings:

Any chance trying this from a Windows VM on a Mac would change anything?

No – I think that could make things more complex.

You could contact support@osmc.tv regarding this.

Sam