Vero 4K+ won't reboot with USB disks attached on 19.1

Hi - I have done a fresh install of OSMC 2021.08-1 on my Vero 4K+ using an SD card with no error messages. I have not set up any Kodi sources, etc - just installed the FTP server through MyOSMC. I have 4 USB hard-disks and 1 USB SDD drive attached through a powered USB-hub. I did the fresh OSMC install without the hub/disks attached. When I attach the USB-hub/disks they are recognised in OSMC. But when I soft reboot (using the Reboot option under the Power menu - or alternatively sudo reboot by SSH) - the system will not boot up with the hub/disks attached. I get a constant loop of the small OSMC logo with ‘Please stand by’ alternating with no signal. If I remove the hub/disks the Vero continues to boot to the OSMC menu. Also if I do a hard-boot (remove hub/disks and power supply, then re-attach hub and then power-supply) it sometimes boots up but not always.

My logs are at :

The Vero is still usable, but it is inconvenient not being able to soft reboot without removing the hub/disks temporarily. I did not have this problem on the previous version of OSMC - it worked perfectly. But I tried a fresh reinstall because I thought an error might have happened with my previous upgrade.

Any help/suggestions appreciated, please.

I should also have said that I have already done a ‘sudo apt-get update’ and ‘sudo apt-get dist-upgrade’ without any improvement.

It’s a bit of a weak suggestion, but it’s probably worth delaying the start of Kodi by choosing the “Wait for network” option in My OSMC > Network.

The log is showing repeated occurrences of these messages:

Aug 15 07:26:54 osmc kernel: snd_spdif_dai: aml_hw_iec958_init,runtime->rate=44100, runtime->channels=2
                                     same source mode(1), stream format=2 CH PCM
Aug 15 07:26:54 osmc kernel: hdmitx: audio: aout notify rate 44100
Aug 15 07:26:54 osmc kernel: hdmitx: audio: aout notify size 32
Aug 15 07:26:54 osmc kernel: hdmitx: audio: hdmi_ch: 0 speaker_layout: 0

Are you using the optical interface?

On the logs all 5 devices are recognized and mounted. My first idea is that your usb hub is not able to provide enough power for all 4 hdds and the SSD. The max. power consumption of an SSD should be written on the label on the SSD.

As a test you could try a test loop by

  • start with only one HDD connected to the hub
  • if that works fine add the next hdd and soft reboot

till you reach the error behaviour. Now repeat this test loop but start with the hdds/ssd which could not me mounted in the test loop before.
If the hdds/ssd (you were not able to mount in the first test loop) could be mounted in the second test loop, you know they are fine but your hub has an issue to handle all of them the same time.

Thanks dillthedog! Amazingly that seems to work!
And no - not using optical interface - just HDMI to TV which is then connected to a sound bar.
But the ‘Wait for Network’ options seems to have done the trick. Many thanks!
Regards - Peter

Thanks JimKnopf also - good suggestion, but problem fixed now, thanks anyway. Most of my HDDs are self-powered, only the SSD is not. And the hub is powered of course. I will try your suggestion if the problem re-emerges.

1 Like