Vero 4K won't turn on

I always leave my 4K on standby. Today I have the red light as usual but the remote won’t turn the unit back on. The remote blue led flashes and I tried a new battery just in case - no luck. Tried disconnecting/reconnecting power and removed dongle and reinserted but still no luck. Is there anything else I can do to try and troubleshoot?

Problem was a faulty power supply.

Hi, you can try to supply the vero 4k with power via one of the usb ports (just for tests). Of course, this only has to happen when the power supply is disconnected from the vero.
You need a cable with USB-A male connector on both sides.

If the vero starts as usual, the power supply has reached the end of its life cycle.

Thanks for the reply Jim. I don’t have an A to A connector. I’ll pick one up and give that a try.

Just tested this: You can also use a USB-A to USB-C cable with a device offering power by a USB-C port.

Thanks for testing that Jim. I don’t have anything offering power with a USB-C port. I do have an OMSC powered hub though. I couldn’t find an A to A cable so ordered one from Amazon. Should be here by next Tuesday.

I’ve rarely seen this work – because the power capabilities needed aren’t advertised…

I just noticed that the led is now switching between red and blue every minute or so. Is that an indicator that the power supply is faulty? It looks like you don’t sell the power supply separately.

Yes – this likely indicates PSU failure.

From the symptoms it is very likely that your power supply is faulty/the voltage is too low.

Some time agao @sam_nazarko provided some links how to order them within the osmc shop, see his post

Other way would be to get one somewhere else, specification: DC 5V, min. 2A, center positive, coaxial power connector male with OD 5.5mm and ID 2.1mm

1 Like

Should I try the USB-A to USB-A via the OMSC hub first before I order a new psu? Are there any negatives to powering the Vero that way?

No – that will get you a boot, so makes sense to try.

Well, it will cost you extra money just for the test. :wink:

The A to A cable is on the way. I’m going to order a new psu anyway.

Got the A-A cable today and it successfully powered up the Vero 4K when attached to the OSMC hub. Unfortunately I’m now left without a USB port on the Vero to attach a portable drive. Hopefully the new PSU will arrive soon.

1 Like

Good to hear! Yes, providing power to the Vero via its USB port is only intended for test purposes and as short temporary workaround.

Do not use a charger as a replacement for the original power supply, as these often do not have a stable voltage.

New power supply finally arrived today and the Vero 4K is operating again. Amazing how much better the picture quality is over the Nexbox I was using as a temporary replacement.
Thanks for your help!