Vero 4K Won't Update, or Reset

Have a 4 year old 4k and 2 year old 4K+, both of which have worked essentially reliably until recently.

But now the Vero 4K won’t update. Noticed it first when an update message went by stating “unable to update” or something similar. Now when I try to manually update it says “nothing to update”, yet it’s stuck at Kodi 18.2 RC1. I’m sure it’s updated since that 2019 date but admit I really only pay attention to the newer Vero4k+.

Anyway, decided perhaps the solution is to reset back to factory defaults via the OSMC menu’s, but after the next reboot, nothing has changed. I know this should work as I used it recently on the other system when the data base needed to be cleaned out. It’s at 19.3.

Quick search found no similar issue so perhaps there’s a simple solution? I’m guessing the two problems are related.

Hi

What’s the version in the bottom left of My OSMC?
18.x is quite old, and you may need to reinstall from osmc.tv/download.

If you can upload some logs, then we can get a better understanding of things.

Cheers

Sam

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

Bottom line, I’m back up and running successfully after installing from an image. While no longer relevant, the explanation is below.

==================

WRT your request for info:
On OSMC Screen - OSMC April 2019 2019-04.1
On System Information: Kodi 18.2-RC1, Compiled 2019-04-1

Strange I didn’t notice it hadn’t updated recently but I typically just use it for videos off the SD card. Regardless, tried OSMC log uploader and after creating logs, it came back with “unable to create url”. Realizing I may have an upstream connectivity issue, I tested a few things that require the internet and indeed subtitles, weather, streaming TV, … all behave like the update; i.e. no error messages, they just don’t work. Even though the settings are all correct and the status says “connected” and local WiFi is fine, I tried changing the DNS addresses to other known sites (blue screened twice) but that made no difference to what worked or didn’t work. So the only plausible solution is a complete reinstall, as the system is hooped for some reason with too many things to fix,

So I used the installer to put the image on an SD, and on the 5th attempt and 3 SD cards it worked:

  • both times with first card resulted in “Please Standby” then absolutely nothing
  • both times with second card, 2/3 through File Install progress bar, got “Installation Fail - Segmentation Fault”
  • third SD card worked first time
    Note I have no reason to believe there are any issues with any of the SD cards. Each was reformatted before every attempt.

As I mentioned though, the system has been very stable up to this point so I’m still a big fan.

We don’t support updating from such old versions of OSMC. It’s best to keep your system up to date regularly instead.

Furthermore it looks (from the RC nomenclature in the Kodi build version) that you were running a test build. Support for these can be limited and there is not always a clear upgrade back to the stable repository when using these.

Sam