Vero and Video short black-outs

#1

I have rather weird issue here with my Vero while playing back any kind of movie.
During playback - and this can happen between 3 to 6 times per 45Minutes - the screen gets black, audio is dead, and then comes back a second later and I have the impression that more than a second was skipped.

As if it has continued playing, but the HDMI link got interrupted.
The debug log has brought up nothing.

  • This happens with any movie/TV Show HD or SD - no difference. m4v, avi etc.
  • TV is a LG 42/LK 45 non Intelligent Connected through HDMI to the Receiver
  • Receiver is a Kenwood KRF_V9300D 5.1 Receiver.
  • Vero is connection to the Receiver through HDMI too. Vero is connected to the local LAN using WiFi 2.4GHz, however in a channel not used by anyone else (All neighboards have their local set top boxes from 3 different manufacturers - all using their own channel :} Only 3 in use). CEC is disabled.
  • Files are coming from a QNap SS839 NAS. It is based on an Atom 1.6GHz CPU - 2GB Ram, and has a max file transfer rate of around 35MBytes/s. File shares are through NFS.
  • Everything is controlled through an old Harmony remote (IR). And I am hit by the IR unresponsiveness too.
  • Kodi is configured to use the MySQL DB also provided by the QNap NAS.
  • WiFi is 54Mbps - but the Vero manages to negociate ~12Mbps link - which is stable.

I have disabled whatever I could on the device (Airplay, zeroconfig crap etc.), metadata extraction out of Media files too.

Music playback works fine - especially when using FLAC - I don’t have these issues.
MP3 - sometimes a drop-out, but very rare. But that happens also on the 3 Raspberry PI’s and XioS DS devices I have in house. PI’s are running Raspbmc x2, and one osmc.

So - what could I do ?
I only have one kodi.log file (debug mode 2) available. However, if one wants me to upload it through the Vero Interface - let me know.

Note - Eventually I could connect the vero HDMI Port to the TV Directly, and audio through ta fiber connector.
Will that make any difference ?

Logs are here: Debug log: level 2

0 Likes

#2

I’m seeing the same behaviour since RC3, i thought it was the episodes themselves but i get the blackout, then picture returns and sound a little bit (second orso) later. I’m not able to help with logs the coming weeks but i thought i’d let you know that you are not the only one seeing this behaviour.

My Vero is hooked up directly to a Philips LED TV with HDMI and CEC enabled and it is connected using ethernet.

0 Likes

#3

Thx. Any chance you could provide details on your setup ?
I’d like to figure out if it has something to do with networking/wifi/nfs etc.

0 Likes

#4

Well as i said, directly connected with HDMI to Philips TV with CEC and Gigabit Ethernet (so completely the opposite of your setup it seems). FIles are served from a Synology through NFS . As far is i can tell it only happened with MKVs. Haven’t had any problems until RC3.

I haven’t seen it happen more than once ‘per play’ though, i’ve seen it once in a 2 hour movie and two times in a 45 minutes TV episode.

0 Likes

#5

Thx. What other formats are you looking at ?
I saw this happening with m4v and AVI format.

If you rip a DVD or redude a movie, what format are you using ? Handbrake with what ?
I default it to Apple TV2 - as it is a 720p format with AC3 Audio if 5.1 is available, if not I leave it to AAC Stereo.

Anyone has a preset for the Vero for Handbrake ? I think that would be nice to have :slight_smile:

0 Likes

#6

Can you see if that does anything? Only times I’ve ever seen issues like these are with Onkyo receivers.

Sam

0 Likes

#7

I’ll be able to check it out end of next week. Not at home until Wednesday night.

0 Likes

#8

Hi,
I have the same problems on my Philips tv. I did some intensive searching a few years back.
As far as I could understand it is a hdmi handshake problem that the philips tv has. Sometimes it is worse, sometimes no problems at all. Usually it is solved by reconnecting the hdmi cable from the tv (I have a direct connection).

With me the audio does continues during the ‘blackout’.

I do not have any technical (logs) data to support my ‘theory’, but it may give you some insights. It also happens (less) with my chromecast and digital receiver.

0 Likes

#9

I’ve been having similar problems with A/V blackout on SD AVI, MP4 & HD MKV files. Seems to be wifi related on my end.

after disabling onboard wifi and moving back to my wifi bridge/extender/link thing via cable (been using it since my original XMBC install on xbox) all seems to work.

I also had issues with the remote cutting out while there was wifi activity (file transfer or metadata lookup)

0 Likes

#10

OK - so far 2 things to note: WiFi and HDMI protocol. I’ll check these. Thx folks.

Note however that I have bought the Vero specifically to avoid my Ethernet-Router solution I had in place before with my Raspberry PI.

0 Likes

#11

Any news? I have tried to debug the issue but to no avail, debugging is on maximum but it does not show any entries at the time of the issue. I do see HDMI disconnects in dmesg but not at the time of the blackout.

If i can find some time i will try to format an SD card with an RC2 image to see if my memory is correct (as i’m pretty sure that i did not see this problem pre-RC3).

0 Likes

#12

I do actually have some news…
It is the WiFi. No problems since I connected a Router configured as bridge on it through ethernet. Also the IR issue vanished - Check this thread: Vero IR Remote Issues

I suspect that slow WiFi and slow data-strains cause high CPU load and latency which is seen as sometimes the black-outs and mostly the IR stutters/repeats etc.

0 Likes

#13

Well that is good to hear, unfortunately i’m not using wifi so that wont fix it for me.

0 Likes

#14

In that case, check your data source. I had also a NAS that was, when heavily used by others, not deliver the content fast enough.

0 Likes

#15

Thx for the suggestion, i have not tested the NAS yet as it is a 5-bay Synology (Atom based) so i’m pretty sure that that is not the problem. I did set the network speed to 100mbit but that did not help. The annoying thing is that there is nothing in the log, neither dmesg, journalctl or the kodi.log with the most verbose options.

0 Likes

#16

hi,

seems like this thread has been silent for a while. this has recently started happening on my Vero as well. i have:

  • HDMI connected to a Pioneer A/V receiver
  • Gigabit ethernet cable connection to my router (no wifi)

have you guys been able to figure anything out?

0 Likes

#17

Did you check if there is something in the Logs ?
Since I switched over to Ethernet - and having a fast NAS, I have no more problems.
Also - I don’t have a “Smart” TV. Means, the TV has no Internet access etc.

0 Likes

#18

not sure what to look for in the logs (and which ones to look in, etc.)
I am connected via ethernet, with a very fast NAS and my TV isn’t smart either.
any ideas?

0 Likes

#19

also, it wasn’t always this way. i’ve had the Vero for a long time (since they came out) and this only started happening about a month ago. nothing in my setup has changed, so i suspect either one of the updates or a hardware/software problem with the Vero itself.

0 Likes

#20

I know it is an old threat, but I have the same problemen with my Vero 4k and Philips TV connected via hdmi and the vero 4k is connected via ethernet. The media is on a Nas and retrieved via NFS.

0 Likes