Vero Audio Breakup

hi sam. i have the original vero, and had to put a 10/100 network switch in front of it to get it to work right. also, on some surroud sound stuff, it ‘breaks’ for a splt second every 30 or so secs, a little crack, but its annoying, is there something i can do?.

i tried switching over to apple mouse, but it doesnt function quite the same, cant hold down menu to get contextual menus. vero remote is hugely clicky

I’ve moved your question to the correct forum area. “Vero Help”.


The fact you needed to put a 100Mbit switch infront of Vero to get it to behave suggests a flow control issue. Does running the following commands help:

sudo apt-get update
sudo apt-get install ethtool
sudo ethtool -s eth0 speed 100 duplex full autoneg on


hi sam - sorry for the late reply i just saw the message this eve. can i run this sudo thing while in kodi on the vero, from vero, in settings? thanks. Patrick

No you would need to run it from command line.
Details how to access OSMC via command line locally or via ssh can be found here: Accessing the command line - General - OSMC