Vero can't see Windows 10 shares


#1

Just received my Vero 4K + having upgraded from an Odroid C2 running LibreElec. The C2 works fine and can browse all of the shared directories on my Windows 10 server, although I do remember that getting it to work the first time was a lot of trial and error with various network settings. As they are running the same version of Kodi I assumed that the Vero would be a drop in replacement, but with the added benefit of being HDR capable.

On setting up the Vero I can’t seem to find the network shares no matter what settings I put in, and have followed various online instructions to try and get it to work to no avail. The Vero and server are both cabled to the same network, and the PC can see and access the Vero happily. One forum suggested that Samba 2/3 compatibility was broken and would only be fixed in the next version of Kodi.

Help?


#2

Hi,

SMB2/3 should be working just fine.
However, you need to add the shares manually. Share browsing has been disabled for security reasons.

This gives you a few options:

  • You can add shares manually, i.e. SMB:/IP-OF-PC
  • You can copy sources.xml from your ODroid C2.
  • You can enable (SMBv1); not recommended, and use this to ‘find’ the shares in Kodi.

This post should help explain things in detail: File sharing with a NAS, media server, windows share or other device

Sam


#3

Hi Sam,

So long story short, tried to do the same again this morning and it worked fine!

Thinking back, this was what happened previously when I tried to set up the C2. I first tried to browse the network for the files, I then tried to find them by adding the locations manually, I then entered the full share addresses manually. All were done many times and failed to find any shared folders on the network. I gave up after a few hours of messing around and left it for the evening. I tried again this morning and it worked first go.

For some reason it seems that both the C2 and the Vero just need to ‘exist’ on the network for a little while before they can see everything.