Vero connection to TV or receiver

I’m using Vero 4k with Marantz receiver and LG55E8PLA TV

TV arc HDMI is connected direct to receiver arc HDMI with high speed cable.

Vero 4k is connected to TV via HDMI.

This setup works fine for most movie mkv files.

I am able to play a variety of movie audio formats: flac, mp3, DTS, AC3 …

Here’s what I’m confused about …

Is it the case that I can’t play Dolby Digital/TrueHD via passthrough using this set up?

If I uncheck passthrough what format am I getting?

If I plug Vero directly into the receiver will Dolby Digital/TrueHD work?

The receiver has BluRay, DVD, SetTop and Game HDMI sockets (no Media Player) which should I use?

Yes, I’ve been through that info but I’m still unsure what happens if I disable passthrough - can’t work out if only 2 channel sound is output or some type of surround

The normal way once you’ve got an av receiver in the set up is to connect any devices such as the Vero to that. That way it’s the receiver that’s decoding the audio. On every receiver I’ve owned there’s no difference between the hdmi in’s - it’s just so you know what’s where so stick it where you want.

…and you’d set the Vero to pass through.

Many thanks … If I plug Vero directly into the receiver should Dolby TrueHD work?

I did try this but the Vero handset locked up (as did TV handset) and OSMC homescreen went dim. I could only get things working again by plugging Vero into TV.

Well, first of all you should configure all audio formats your Marantz is capable of in the settings → system → audio menu. For this you should have set the settings level to advanced or expert, see picture attached.

If you’re using an audio format which you cannot pass through to the AVR, it will normally converted to PCM, using the number of channels you configured in field number of channels.

There is a special if you have configured number of channels to 2.0: In this case you can convert the original audio format which is not configured for passthrough to 6 channel AC3 (dolby digital), see last picture.

If you’re not sure what to configure, you can transfer a log set using the following instructions when the Vero is connected to the Marantz and you played a working video:

You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

That’s a great help - thank you.