Vero crashes when viewing pictures

I recently uploaded some new pictures to my USB harddrive connected to my Vero. I have numerous albums loaded that have always worked fine but the latest album contains more pictures than the previous ones and the images are larger in size.
This folder contains 219 images averaging between 2,500 KB and 5,000 kb.
When I view the folder all of the thumbnails are visible but when I try to view the images, the first one loads, then any attempt to navigate to a 2nd picture, either directly or by starting a slideshow causes the system to black screen and reboot.

There seems to be some suggestion on the forum that’s it’s due to the number of files I have within the folder, does anyone know what the limit it or have any kind of work around?

You could easily try and find the limit by first having 5 pictures in there, then increasing to 10, 20, 40, 80 etc. should take about 5mins. If it fails with just a few images in there then directory size possibly isn’t the issue.

I think read somewhere about this being a potential Kodi issue where a large number of images can cause a crash.

Sometimes a corrupt image can cause the crash too. As @jb2cool suggests, it’s not a bad idea to try with a few images and see if the issue still persists.

A debug log may give some clues.


That’s a good point Sam. I once had a jpeg that I wanted to use as a wallpaper. I could view it ok on the PC but whenever I used it on the Pi (This was back in Raspbmc days) it’s instantly crash OSMC. I don’t know what was wrong with that particular image file but there was something fundamentally broken about it.

Good call. I created a new folder and just copied 2 files to it and had the same issue. So it’s not the number of files. I can view both images OK if I pick them as the first image, so it doesn’t appear to be a corrupt image.

Any other ideas?

I’ve just gone to the upload logs screen (not used this before) there are a lot of logs on option. Which one(s) would I be best uploading?


So viewing the image is OK, but scrolling through them is not? That is odd.

Enable debugging via System menu first, then just upload all logs.


done. do you need any more info to find the logs?

I need a link to the logs. A URL should be printed on your screen when you do this.

http://paste.osmc.lo/ eqirugelak


update. I’ve just checked some of my older image collections and they are now failing also, so it looks like something has changed as these have always previously worked.
Also I’ve noticed that if I view and image and then ‘exit’ back to the thumbnails and select another image everything is fine. The error only occurs when I open an image and try to navigate directly to the next one.

15:55:33 T:1355805680   DEBUG: Thread BgPicLoader start, auto delete: false
15:55:34 T:1355805680   DEBUG: Finished background loading slot 0, 0: /media/Seagate Expansion Drive/Pictures/BVI 2016 10/20160420_091946.jpg
15:55:34 T:1956331520   DEBUG: Loading the next image 1: /media/Seagate Expansion Drive/Pictures/BVI 2016 10/20160420_102832_002.jpg
15:55:35 T:1355805680   DEBUG: Finished background loading slot 1, 1: /media/Seagate Expansion Drive/Pictures/BVI 2016 10/20160420_102832_002.jpg```

Did the log you uploaded cover a crash? I can't see any issue in your log. I will try and replicate this issue locally. Does copying these files to the internal storage help?

yes, the 2nd image never displayed. I’ll try coping the files locally and see what happens.

copied 2 images to the local /tmp storage and got the same result. tried to move to the 2nd image causes a reboot.

Can you send me those two images via a private message if they are not personal?


tried but the message system seems to have a 2mg limit.

If you can upload them to Dropbox or Google Drive and send me a link that is fine too.

sent you a dropbox link

Did you manage to look at this Sam? I tried changing the skin to the standard OSMC skin in case there was a problem there but it made no difference. the log file shows

08:39:53 T:1956810752 DEBUG: CGUIMediaWindow::GetDirectory (/media/Seagate Expansion Drive/Pictures/BVI201610/)
08:39:53 T:1471149040 DEBUG: Loading items: 2, directory: /media/Seagate Expansion Drive/Pictures/BVI201610/ sort method: 0, ascending: true
08:41:47 T:1956810752 DEBUG: Loading the current image 0: /media/Seagate Expansion Drive/Pictures/BVI201610/20160420_091946.jpg
08:41:49 T:1625723888 DEBUG: Finished background loading slot 0, 0: /media/Seagate Expansion Drive/Pictures/BVI201610/20160420_091946.jpg
08:41:49 T:1956810752 DEBUG: Loading the next image 1: /media/Seagate Expansion Drive/Pictures/BVI201610/20160420_102832_002.jpg
08:41:50 T:1625723888 DEBUG: Finished background loading slot 1, 1: /media/Seagate Expansion Drive/Pictures/BVI201610/20160420_102832_002.jpg
08:41:58 T:1671599088 DEBUG: script.module.osmcsetting.updates : - blurp 702 - SlideShow.xml
but the 2nd image never appears on screen. the system soft reboots and a new log file is created.


I couldn’t replicate this issue myself.

I will try again after the May update (new kernel and some userland changes) which may improve things.