Vero doesn't recognize USB DVD drive

Situation: I’ve been using an external USB DVD drive for DVDs on my Raspberry Pi with RaspBMC and it worked. When I inserted a DVD (sometimes after restarting RaspBMC), a menu item came up.
This doesn’t work with the Vero! The drive works, it spins up so it gets enough power (I use a Y-cable and a USB PSU to ensurethat it indeed does get enough power) but the Vero doesn’t display any menu points related to DVD playback.
What to do?

What skin are you using ? If you go into Video->Files do you see anything appear there when you insert the disk ? (Normally any auto mounted external volume should appear here)

Try booting up without the drive attached, connect the drive, and then insert a disk, then capture and upload your dmesg with the following command:

dmesg | paste-log

Paste the URL here.

What can I say?
I have an external USB DVD drive, connected via a powered hub.
When I insert a DVD, it spins up and I get a PLAY DISC item (admittedly using Confluence skin). I can see the device with lsusb, and can see the DVD is mounted with mount command - these require use of an SSH login, and I don’t remember it you have to install apackage for the lsusb tool.
I did have once the situation where I had to reboot to get things working.

I use the Vero skin. Will try with Confluence skin and will upload the dmesg output when I get home.

Here’s the URL
Additional info:

  1. The disk appears in the file overview, opening it however reveals the Linux file system
  2. It doesn’t work in the Confluence skin either


I have explicitly enabled optical drive in the Kodi configuration stage of the build, so I’ll attach a DVD drive myself shortly and find out what’s going on.


Is there anything I can submit to help? I am kinda a nerd so get technical.

I’m having the same issue with my drive.

Lets say I want to play an MKV from a disk. I go to videos, see the title of the disk but when I click it I see the Linux folder structure same as above.

I will revisit this tonight


Hello, I’ve just installed the latest build and the DVD drive still doesn’t work properly. Vero recognozes it as an external hard drive instead of offering me the option to play a video DVD.

Make sure there is no disc in the drive when you turn the drive on and boot the vero. Failing that please upload your debug logs taken with the disc inserted.

I’ve done the following steps

  1. Remove the DVD from the drive
  2. Reboot the Vero via the menu item
  3. Put in the DVD
    The result is the same and here’s the log

I can’t see anything obvious wrong in the log - what Skin do you use ?

If it’s the OSMC skin try changing to Confluence and rebooting then see if you get a Play Disc item appearing on the main home menu when you insert the disc.

Yup, Confluence displays the “Play disc” menu item. Playback seems not to work though, it’s stuck @ a timestamp of 0.