Vero don't use WLAN AC

Hi Guys,

I have an Vero 4k at home and an fully AC WLAN.
But… my Vero only connect to the 2.4 Ghz so the max Speed is limited to 72Mbit/s.
For HD and 2k it is okay but 4k don’t work with an single WLAN N Stream.

How I can fix it?


Is your AP setup with separate wlans for 2.4Ghz and 5Ghz? I seem to remember that using the same name for both wlans can cause this problem. Try a different name for the AC wlan.

You can connect manually via the command line; but we recommend using different AP names for 2.4/5Ghz. That way you always know you’re connected to the right network


no, the AP don’t use different names.
WLAN AC use both, 2.4 and 5Ghz. So for an fully AC Support it need to be the same name.
If I use different names for it, it is simple an 5Ghz based WLAN N.

Do you have any informations how I can crate an AC connection via the command line?


It’s possible to have a 5Ghz network only for 802.11ac.
I’m not aware of a router that doesn’t support this.

But see Connection to a 5GHz hidden wifi - #2 by sam_nazarko for info on connecting via command line

@GON, I’m not sure where you got the idea that 2.4Ghz is required for AC speeds. Read this:

Clearly states that AC speeds are available using only 5Ghz.

Sorry, that was my fault :frowning:

I have try to connect manually via connman but… It only connect to the 2.4Ghz network.
I have try to google any solution to ‘force’ use the 5Ghz network, but I think connman can’t to this :confused:

@GON, you do know that if you have any N devices that can use 5Ghz that with your current setup you will never get AC speeds? Once an N device is connected at 5Ghz, it will slow the entire network down. Separating the networks will prevent that. (Of course, 5Ghz N devices would have to connected at 2.4Ghz if you do that.)

It’s worth trying separate names for the networks. You can always change back if it doesn’t work out.

I know what you mean, but every of my Network hardware use WLAN AC.
And my network works really well. For eg. my Notebook have fully WLAN AC (3x3) support.
If I’m inside it connects via 5Ghz and have easy speeds up to 50 MB/s.
When I’m outside, it connects via 2.4Ghz due to the limited range of the 5Ghz network.
Even my Printer can do that. (I know, at a printer this is… Not useful)

This is how every normal WIFI Client works.
I have currently around 40 WIFI Clients. Everything works fine and fast.

Now I have to change this working system and have to explain my Wife and Kinds that they need to manually switch to an other WIFI Network if they outside due to the “limited” WIFI functionality of one Vero?

Post the output of services and connection.


If all of your devices are AC, then re-name the 2.4Ghz network. Then you would only have to reconfigure the devices that still need the 2.4 network.


What do you mean exactly with connection? :no_mouth:

Internal Download Speed:

Still no answer, or change.
Please add any fixes that the vero prefer 5Ghz AC.
Every current device can do it, only the vero can’t do it or do it wrong.

Currently, it connects via 5GHz WLAN-AC (with 80Mhz) after booting, but after some minutes, it go down to the 2.4Ghz network.

It won’t degrade to 2.4Ghz unless there’s a dropout.

Check your WiFi router and environment. As recommended however, it is best to put the two networks separately

No, it is not. Every modern network use 2.4Ghz and 5Ghz on the same network name.
I can’t make two different networks only due this BUG of the vero.
eg. my Smartwatch syncs the WIFI Networks with my phone. My Phone use the 5Ghz network. My watch only supports 2.4Ghz. When I make two different networks I cant longer use the WIFI on my Smartwatch. (only one of many examples)

I use an brand new 300 GBP router. With my Laptop I reach arround 120 MB/s (FASTER THEN 1Gbit/s LAN), thanks to 4x MU-MIMO in the same room.

I can’t play HD Movies on my Vero only due this fu**ing WIFI Implementation. So my 120GBP Veo 4k is absolutly useless.

Please give me simple an option to force use WLAN AC (5Ghz). Then I’m happy.
Otherwise I need to buy one of these cheap OenELEC ACEMAX boxes. They are ceaper (half price) and work perfect with my network.

Why would having separate SSIDs prevent your Smartwatch from seeing your phone? I have my router setup like that, and devices on the N network see devices on the AC network just fine.

Doing a little Googling on this question gives mixed results. About 50/50 to use same/separate names. So there really is no ‘right’ way to do this. So why don’t you just re-name the network with the least amount of clients, and try it? You can always switch back if it’s a problem.

… Okay… You have say it. There is no whay to do it wrong.
I have my setup and everyting works fine. Only my Vero 4k is not working.

So, we can talk the next days why I have this setup or how I can change my setup or we can find a solution why only the Vero 4k have problems to prefer 5Ghz networks.
The last hrs I have google a bit how i can change the WirelessMode on an Debain client.
And it looks a bit like no many people have this problem. And mostly the WirelessMode will be set during the driver compiling.

Im not new to Linux, but I don’t know mutch about wireless driver compiling. So, you have build the debian system for the Vero 4k and you know “how it works”.
So now my question: Is the only way to force use WLAN-AC to recompiling the drivers?
Or is there any other way to force use it, so that the Vero 4k don’t switch back to 2.4Ghz?

I have seen, that the Ubuntu Network manager have on option to set an “BAND” if the wireless device is using and Mixed mode. So, there is an way to do it without recompiling. Do anyone know how I set this in connman?


I am sorry you are still having problems with this.

I’m not sure if you realised, but OpenELEC has the exact same network manager as OSMC. So your ‘cheaper’ boxes will be exactly the same in behaviour. Both distributions use ConnMan.

But I’m sure you paid a bit more for a reason. Support.

So this sounds like a plan. We will add support for this, and I’ll let you know when it’s ready.


I’ve never used this option myself, but you might want to look at wpa_supplicant.conf and the option(s) to specify which frequencies to use.

The link mentions freq_list and scan_freq. I suspect the first one might be the one for you but you would need to experiment with how it works and which 5 GHz frequencies you need.

If you go down this path, you’ll probably also need to change /lib/systemd/system/wpa_supplicant.service to tell it to read the conf file.


Don’t you have band steering on your router? It might help, some ac devices are very sensitive to auto switching to the 5ghz, my galaxy s7 and my lg tv like more 2.4ghz than 5ghz on my network, I have to force it sometimes, at least on my network that is build in ubiquiti ac aps and switches.