Vero DVD.ISO Pixelation (solved)

Good day @sam_nazarko, @DBMandrake

Solving the Framerate Dropping on the Vero (good job btw) has caused the Image quality to be very poor.
Initially posted by @supersonicjohan85 DVD (ISO) MPEG2 Playback Choppy - #99 by supersonicjohan85

What happens is that the video plays back smoothly, but the image is blocky/pixelated on all 1:1 dvd.iso files.

Look to the curve of the hill on the far left side
1 - Vero… picture 1 scaling issue pixelation

2 - Vero… picture 2 with deinterlacing turned off… picture looks 90% great (small amount of pixelation, hard to see in the picture but noticeable on the tele)

  1. Pi B+ … picture 3 looks 100% great (on same physical hardware as the Vero)

Hopefully splitting this new issue into its own thread is appropriate. If not, MOD please remove.

Bump -> @sam_nazarko, @DBMandrake
Anything else I may supply?

Thanks Crew

Bump -> @sam_nazarko anything at all? The Vero has gone back into storage until/if the blocky/pixelated dvd.iso issue can be solved.

Hi Landspeeder,

I have not forgotten.

The poor picture quality is due to the new rendering changes in Kodi 15. In the next update, you will be able to pick the chosen rendering method. If you pick the old one, you should see good picture quality again



Lovely! My fingers are crossed. I assume this rolls into the monthly (so about 4 weeks away)?

Yes that’s correct


@sam_nazarko Perhaps I am acting the dullard, but where does one change the rendering method in this update, and what is the title of the old method? Looking forward to finally being able to put the Vero to use with our media collection!

Bump… anything?

It depends on what skin you’re using, and what kind of input device, but generally you would press OK during playback to bring up the onscreen controls then go to the video options - you should find deinterlace choices in there.

@DBMandrake. The OSMC skin and CEC. Ok… i did not know that Deiterlace = render method. Thanks!

Hi Landspeeder

I must apologise. On any update day I open dozens of tabs to track any potential issues, and occasionally one gets closed by accident.

Please let me know if you’ve not found the right setting, and also let me know if picture quality isn’t improved.



@sam_nazarko @DBMandrake

How do I set Deinterlace Off as the default for ALL videos? I am using the OSMC skin on the Vero.

Framerate and picture quality are now both on par with the B+ and B2 when I manually turn Deinterlace off, good job! For the first time, I have been able to use the Vero for my movie collection :slight_smile: (DVD.iso).

I save my TV series DVDs with the menus rather than just the movie… some of these that play fine on the B+ and B2 do not switch over to video, though I can hear sound playing and the lower left shows a black box with a white video camera icon on it. Is this a known problem, or should I ‘submit a ticket’ in another thread?

In the same dialog where you turn off deinterlace, there is an option to save the settings as default for all videos.

Thank you! I spent hours looking through menus/double checking/etc. The bottom entry I saw on this menu was Stereoscopic 3D mode of view… didn’t realize I could scroll down!

Whenever you save settings as defaults, all of the settings in that dialog (except the master volume) are saved as defaults for all videos you play in the future, however you can change these settings for individual videos without choosing to save as default and it will only affect that one video.