Vero, Force HDMI Mode like RPi?

I have a question before trying to get a Vero :slight_smile:
When I want to power on all components (TV, AV-Receiver etc. via “master-switch”) at the same time, I have to rely that the mediaplayer already knows which HDMI-settings are needed… as the samsung-TV needs quite a long time to be available for “negotiation”.
On the RPi its possible to force the HDMI-settings, hotplug etc. which works absolutly fine in my combination. Before I upgrade to the Vero I would like to know if this is also possible with Vero ?
Otherwise I would have restart manually it after every power-on (like some other mediaplayers) which would be a No-Go with my TV & Receiver :frowning:

Hi I own a Vero and use it with a projector which is often turned off when I use the Vero to stream music to my AV receiver.

I set up the Vero to 720p in the normal settings. To my surprise is looks like the Vero behaves just fine even when the projector is turned on after vero has booted.

AFAIK there is no config.txt for the Vero where you can force a specific resolution. But this is not a problem for me because it always worked so far with my setup

Thanks for the reply, but I think this is a different situation. You switch of the projector after Vero & projector have sorted out the hdmi-settings (resolution, mode etc.)… after this has happened I can also restart my TV without loosing the settings. But what happens if you switch on the Vero first and the projector a few seconds later (maybe you can even switch them both on at the same time if the projector-hdmi needs a few seconds to be available)… then I would guess you will have to hard-reset the Vero ?!?

Hi Frank, it is mostly the other way round. I always start my Vero before I start the procector. With my main switch I power up the AV receiver, the HDMI switch and the Vero. I can then listen to music streaming from my iPad without the projector running. When I turn on my projector some time later ( seconds, minutes or hours later) the Vero is displaying the screen correctly with 720p. This is the value I entered in the KODI settings when I configured the Vero at first time usage.


@chris_vero has some good tips here.

You can manually specify the resolution in a file called /boot/uEnv.txt. You can edit this via SSH:

sudo nano /boot/uEnv.txt

By default, you will see 1920x1080. You can change this to 1280x720 (720p)

Hope this helps


Hello, thanks for your replys. The resolution is set in uEnv.txt as by default…
But in my Setup, a powerOn of all components at the same time just fails using a cubox (imx6):
Samsung F6500 Marantz 6004 Cubox

And it really seems to be a problem with the HDMI-“Handshake”. When I restart (power-off and -on) the cubox about 10 seconds after Samsung & Marantz are powered on, everything works just fine.
I already considered letting the cubox running 24/7 (although the idle-power is with 5W much more than the stated >1W in some forums)… but then my NAS won´t go to standby as Kodi is always accessing the shares… it´s really a shame :frowning:

I´m suprised that I´m apparently the only one experiencing such issues :frowning:

So this is NOT a vero but a cubox?

As stated in my initial post “I have a question before trying to get a Vero” :smile:
I would like to get a Vero, but I´m afraid I will run into the same problems as with the cubox… at least nobody was able to tell me how it could be solved on a Vero.


troubles you describe is a BUG.

Oh ok, I wasn´t very successful using google on this topic… is this a know bug with an already ongoing discussion ? Maybe you have a link where I could follow the topic ?


Does Vero like RPi has a possibility to supply edid in file?

Not at this time,