Vero Included IR 'double' clicking

Apologies if this has been answered… i did search but couldn’t find anything. Out of the box the Vero seems to register two clicks for every one I make on the remote. Clearly this makes it unusable as I can only access the ‘even’ menu options!

I’m happy to edit config files via ssh if necessary.

I’m hard wired to the network… no wifi in use.

Thanks for your help.


Is it literally out of the box, or have you run updates ?

I’m not aware of anyone else reporting it clicking exactly twice per button press.

Out of the box… i believe the auto-update is turned on though.

Is there a mechanism to reset… re-install the box from scratch?

Thanks for your response.


Auto update is turned on by default but depending on which version of OSMC your vero shipped with there was a bug that caused automatic checking for updates to not always work. So to be sure you could go into OSMC settings->Updates->Manual Controls, and tell it to check for updates now.

I would try that first. If you want to do a fresh install to RC2 you would need to download the installer from Download - OSMC and plug the SD card into your Mac/PC to re-image the card.

OK… I’ve done the manual update… issue remains.

I have also been trying to get the TVHeadend server from the app store to work… but to no avail. Research on here suggests that there are some issue with that so I’ll wait.

are you using your TV remote or the vero remote?

I’m using the vero remote.

I’ve just done a reinstall (removed sd card, re flashed from website, re-inserted, etc) and see exactly the same effect. In fact, i struggled to choose the language at the first step!

Is there a ‘sensitivity’ setting anywhere? I’m happy to edit config files.

Is it always clicking exactly twice, or is it just repeating a random number of times ?

If you have access to a USB keyboard, try deliberately changing the type of remote in OSMC settings to something else other than the osmc remote and see whether it stops working entirely or just stops double responding. (You’ll need the keyboard to change it back again if it does indeed stop working completely)

I haven’t heard of anyone else reporting the same problem so I’m wondering if you have a faulty remote.

Edit: or you could set up the XMBC remote app on a smart phone as a backup controller while messing around with the remote settings…

I have similar behavior with my TV remote. The code is sent to the vero both by ir receiver and by cec of my TV.
Maybe your TV recognizes the vero remote signals and passes those through via Cec?
Just cover the vero receiver and see if you get single click behavior then or no clicks at all anymore

Ahhh… nice idea. Unfortunately not. Tried covering the vero box and also the tv receiver.

Still happening. Maybe I have a faulty unit?

I am experiencing the same issue with my original Vero remote.
Sometimes I have to “double click” until the command is registered.
Pretty annoying and I am not sure what is causing the error.
I have installed all available updates.

Not the same issue as OP. They say that their button is registered twice.


It’s unlikely your remote is faulty, they usually either work fine or not at all.

Are you using the supplied HDMI cable?


I’ve experienced both of these issues, clicks not registering so I have to click again and one click registering as multiple clicks. I’m using the supplied HDMI cable. The behavior is erratic and unpredictable and happens about 5-10% of the time.

I have the same problem. sometimes the remote clicks are not registered at all and other times the screen goes crazy with the selection going up/down or left/right

1 Like

I have exactly the same problem. Have updated it but still. As soon as I click on the vero remote, it turns crazy. You can hear from the device click, click, click, click, click… indefinitely, faster and faster.

Anyone has any idea about what´s going on?

I have an external device mounted and WiFi connected… :frowning:

It´s very frustrating!

Hi all,

I’ve been already using my amazing Vero for 2 weeks and I love it. And also love being part of this project (writing here and providing feedback, even if I am not an expert in such matters).

Anyway, the multiple clicking problem seems to be solved, although I am using now the app from my Android. But is it true that sometimes, with the remote, I am able to control my device without issues.

Does that respond to an update from you guys?
Thank you anyway!!

What happens now is this randomly 1-sec cut downs. Going to write it in a proper post though.
Thanks again!

Same problem here. I push volume up and go to the top level.
Play and Play/pause without an end.
The problem disappear after a while but in unpredictable way it come back…
Switched to CEC tv remote, but this is very bad…

1 Like