Vero+ MPEG-2 DVD Playback Choppy/judder

Hi, I have started to backup all my DVD and Blurays to my NAS to save some cupboard space. I have a Vero+, the Blurays are fine but DVDs are playing very juddery and out of sync with audio. The audio itself sounds fine, the video seems to be struggling doing an almost slow then catch up every second. They are MPEG-2 PAL 576p, no subtitles enabled. I’m guessing it’s a frame rate issue of some sort. I’ve found quite a few posts about MPEG2 playback issues but they are older posts. I’m running the latest stable release at time of writing. Any help would be awesome please.


To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

This will almost certainly be a settings issue which we can resolve with some logs.

Hi Tom and Sam, I really appreciate the response. I’ve now created the logs using in inbuilt GUI functions (very useful!). I enabled debugging, rebooted vero twice and then played one of the movies with the issue for 2 minutes. If you need me to anything more let me know. The logs URL is

After uploading the logs I skipped through the film a bit and the video gets worse almost being in slowmo then jumps to try and catch up.
Sorry I realise this probably isn’t very helpful but any assistance you can give would be great.


Please set gui resolution to 1080p.
Please set Adjust display refresh rate to start and stop.

Then try playback testing mpeg-2 again.

Thanks Tom.

Hi Tom,
Thanks for the reply.
It plays smoother but seemingly too slow as now the audio is out of sync, every few seconds it skips presumably to try to catch the audio and video back up but then drifts out again. Doesn’t seem to be ever fully in sync and sometimes a few seconds out.

1 Like

Can you now post a new log now?

Hi Sam,
My apologies, I neglected to reboot the vero after making the two changes Tom suggested. Since doing so the test video plays great. I’ll get some more DVDs to test with and post back any issues. I do have one last question if you can please, with the resolution change of the GUI to 1080p does this still mean than any titles above that will play at the correct resolution and not be down scaled?

Yes, that’s what Adjust display refresh rate option is for.

Ok great thank you. Just with it saying refresh rate and not resolution I wanted to check. Thank you everyone

1 Like

Had the same problem as mike6 and Tom’s Solution also worked for me :smiley: :+1: