Vero not detecting HDR

I have a TCL805 and it appears the Vero 4K is not recognizing it’s HDR capabilities. I have several 4k HDR movie files that play fine (in HDR) when played directly by the TV. When I play those same files via the Vero 4K, the files do play but HDR is not utilized. My TV normally displays the HDR logo in the top right corner of the screen when it is activated. It does this correctly when played through TV but not for Vero.

I have tried enabling and disabling the HDR auto-switching feature and the “always on” refresh rate setting. I have also tried modifying the rc.local file to play “444,10bit” but still no change. I ran the display capabilities command and it shows “0” for SDR/HDR which leads me to believe it isn’t properly detecting my TV’s capabilities. Any help you can provide would be greatly appreciated.

Make sure you that you shut down the Vero. Then with the TV powered on, turn the Vero back on.

If that doesn’t fix it, then try another HDMI cable.

Can you upload a log via My OSMC → Logs?



@sam_nazarko - Thanks for the quick reply Sam. Please see my complete full log(s) pasted via the link below. I apologize if you don’t need to looks at all logs as I was unsure of what to select/de-select.

@bmillham - Thanks for the suggestions Brian. I have already tried doing both and still no luck. :frowning:


Your TV is indeed not advertising HDR capability. This may be because you are plugged into an HDMI input that doesn’t support it (unlikely as you are plugged into HDMI2) or there may be a setting on the TV that enables HDR support generally or for that HDMI input. (called HDMI mode or similar).

If that doesn’t work, try restarting Kodi (Power->Exit) with the TV turned on to re-read the EDID.

1 Like

I think its pretty common TCL problem, I remember lots of people having problems getting HDR to work properly with their Ps4 pro and Xbox one x

Thanks for your suggestion! I suppose I should have looked over my TV settings a bit more carefully before posting, but you were right. I had to change my HDMI2 Mode from “Auto” to “HDMI 2.0”. Once I changed that setting my TV detected all HDR content played from Vero 4K. Thanks for the help and suggestions everyone.