Vero or skin issue?


I’ve tried multiple fresh installs on my folks’ vero 4k and downloaded latest updates each time via myosmc. For some reason I’m having difficulty switching skins and wonder whether it’s an issue with the install or the skin itself (Arctic Horizon, which often hangs on ‘initialising skin’ when the skin does switch over and doesn’t let me back in). I’m not having any problems with this skin on my 4k+ however.


Was thinking this may be a skin issue, although no problems on my 4K+, so stopped mediacenter, issued mv .kodi .kodisave and started again without Arctic Horizon skin installed. Still having trouble switching between osmc/estuary skins. Just hangs and returns to current skin.

I am having the same issue. I have been using Arctic Horizon was months now, but tried to switch to the default OSMC skin and it would just revert back to Arctic Horizon. So I tried a different skin and that one worked. However, when I tried to switch back to Arctic Horizon it would never initialize. It just reverts back to the previous skin. I can keep changing skins as long as it is one I have never used. Once I use one and then switch I can never get that one to initialize again. Not sure what is going on.

Log for anyone interested:

Ok, I can reproduce the issue. We will look into it.

Great, thanks!

@anxdpanic has made some changes that should improve things, but there are a couple of other issues we want to try and resolve before pushing an update, so it might be a couple of days before this reaches your parent’s device as a stable update.


In the meantime you could try the following as a workaround (no guarantee it always works)

  1. disable script My OSMC at GUI->Settings->Addon-browser->MY-addons->All
    (some skins have a different path in their menu structure)
  2. change your skin at GUI->Settings->Interface->Skin
  3. enable script My OSMC at GUI->Settings->Addon-browser->MY-addons->All
    (some skins have a different path in their menu structure)
  4. restart the mediacenter or reboot

Thanks for looking into this. No problem re timeframe, just pleased you’ve identified an issue.

Hi. Skin switching seems much better now. Not sure if you’re still in the process of fixing other things, but in case it’s helpful, I’m still getting stuck on arctic horizon skin’s ‘initialising skin’ splash screen, but only after I clean my video library within media settings. Happens every time I do this after restoring from a backup. Logs if useful…

Is it possible that’s a skin specific bug rather than an OSMC one?


Just tried installing skin fresh instead of using a backup, which has worked fine. Maybe it was something to do with the backup which was made before recent updates. Or a skin issue. Anyway, sorted, thanks.

Spoke too soon! Seems adding widget shortcuts to homescreen still messes with things. Have contacted the skin author to see if it’s an issue on his side, although my 4K+ does not have any of these problems, weirdly.