Vero problems

#1

I have numerous problems with my Vero.

Since I got it in April 2015, I’ve had the issue with the remote acting like its being held down for seconds at a time. I.e. when quickly pressing down once, the Vero acts like I’m holding it down for 2-3 seconds. This happens close to 100% of the time, whether connected to a network or not. No updates have ever changed anything (The problem persists for me as of 2017.07-1). Doing a little research showed me a number of other people have had the same issue and it doesn’t seem to have ever been resolved. It seems to be software related, as I can quickly press the remote button and move the remote completely out of sight of the sensor (under a chair or pillow) and it keeps scrolling. Pointing the remote at a digital camera confirms that the LED stops blinking after releasing the button.
Although this is quite disappointing, being one of the main reasons I got a Vero vs something else like a Raspberry Pi, it wasn’t a deal breaker as I can use Yatse to control it with my smart phone.
EDIT: Re-installing 2017.01-1 seems to have fixed the remote issue somehow (??). Last time I reinstalled 2017.01-1, the remote still acted weird.

Just yesterday, a new issue popped up. Video playback became EXTREMELY choppy. It didn’t matter if it was a h.264 1080p video with DTS-HD sound or a 320x240 Divx file, all videos were getting stuck buffering endlessly. I stream all my videos from a HDD hooked up to my router, and the Vero is connected via Ethernet. My phone and my computer and every other device can stream content from the HDD just fine without issue, so I’m not sure what caused that to happen all of a sudden.
I was on 2017.01-1 at the time because of HD playback issues with newer OSMC versions. So, I tried updating to the latest 2017.08-1, but it didn’t help. A fresh install of 2017.01-1 didn’t help anything. Navigating network folders is also painfully slow, taking 10+ seconds to change folders every time. Nothing on my network has changed in quite a long time, so I doubt it’s how my network is set up.

Also, under a fresh install of 2017.07-1 (2017.08-1 is only available via update at the moment), I cannot connect to my networked HDD at all. It should show up under “Windows network (SMB)” but doesn’t. It’s very odd because my router shows up under UPnP devices, but I can’t actually connect to it. And attempting to connect manually by entering in the IP and login results in “Connection timed out” immediately. I’m not sure what to make of this issue-- it’s definitely connected to the router just fine as it can download the update via the internet and I can control it with Yatse just fine.
It appears this problem only exists for me on 2017.07-1. I did a fresh install of 2017.01-1 and my HDD shows up under “Windows network (SMB)” as it should.

Sorry for the lengthy initial post. I just wanted to include as much info as I could think of. Any ideas on what could be causing any of these problems?

0 Likes

#2

Hi

I’m sorry to hear you are having problems with your Vero.

The remote issue with repeat presses was quite prominent with Vero 2, and this occurred when the USB RF dongle was inserted in a side port instead of the rear USB port. However, I think you are using a Vero 1 (IR) and this issue shouldn’t apply to you.

There were/are some issues with 1080p material on Vero.
However this is only an issue with Kodi Krypton, and older versions that do not use the new VideoPlayer design still work fine. What I’m not quite sure of however is why you are experiencing the problem with low bitrate content. Some logs might help here.

Which version did you update from?

After WannaCry (2017 cyber attacks), SMB browsing is now no longer possible. This is for security reasons. Adding and using share however will still work.

Sam

0 Likes

#3

Thanks for the quick reply!

After enabling debug logging, CPU-KODI shoots up to over 100% any time it tries playing video, regardless of format, and the system seems to freeze temporarily any time I switch folders on the network drive (the debug info in the top left stops updating). Video fps, according to the debug info, drops to under 10 during playback, and pauses repeatedly with some files.
I’m on 2017.01-1 right now. I installed it from my PC onto the SD card (wasn’t updated).

EDIT: Here is my log file:
http://paste.osmc.io/gifibivumo

Regarding SMB on newer versions. I don’t mind if browsing is disabled, since I know all the info to do it manually. Shouldn’t manually entering the IP/login still work?

0 Likes

#4

We’re going to need complete logs, not snippets. There are simple instructions linked below for providing them to our own paste site so that no one has to download files. Initially, there will be no need for component specific logging, just be sure debugging is enabled.

https://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/

0 Likes

#5

http://paste.osmc.io/gifibivumo

0 Likes

#6

Yep.

IP is recommended over hostnames, so you’re doing things in an optimal manner.

For legacy devices that don’t use SMB2/3, you may need to configure settings under Kodi’s System menu. This is a new option added in the last update

Liquid.Television.S01E03-Nanto.avi must be an old file.
Old Divx is rife with continuity errors.
So decoder gets confused.

Would be good to know if disabling HW accel fixes this; and if you played the file successfully with an older version of OSMC

Sam

0 Likes

#7

Everything was working fine until a couple days ago. I deliberately picked files that I’ve successfully played back before without issue. The 2017.01-1 I had installed, I installed directly onto the SD card after having issues with later versions playing HD content-- I didn’t update from a previous version to it. I also didn’t update or change anything between when it worked last and when this started happening.
I’ll see if disabling hardware acceleration does anything.

How do I disable HW acceleration?

0 Likes

#8

If you have the old SD / installation, please post some logs so I can see which version you updated from. Otherwise it may be tricky to debug why you are now experiencing problems.

Should be under Settings -> Video

0 Likes

#9

I didn’t update. I downloaded the installer for Windows, and installed 2017.01-1 directly to the SD card.

If you’re asking about my installation before that, I kept it up to date until maybe April or May when I noticed HD video wasn’t playing back properly. I don’t have anything leftover from that installation, as the installation of 2017.01-1 mentioned above wiped the SD card.

Regarding HW acceleration, I see the menu for it but what do I change to disable it? “Render method” is black and can’t be changed from “Auto detect.”

0 Likes

#10

Its under settings -> player -> video its called amcodec

I think you’ll need expert level settings enabled to see it

0 Likes

#11

There isn’t any “Player” category in Settings. I have my Settings set to Expert.

0 Likes

#12

Then you should be able to find it rather easily by simply exploring within settings.

0 Likes

#14

There is literally nothing in any part of my Settings menu regarding hardware acceleration. Logic would put it in the “Acceleration” category under “Video,” but there are no options to change anything other than “Enable HQ scalers for scaling above” and "Limit GUI updates during playback."
Is it possible the menu option to enable/disable hardware acceleration was added after the version of OSMC I’m running? (2017.01-1)

0 Likes

#15

No. Things have changed, but the option is still there. Make sure you are scrolling down on each menu

0 Likes

#16

I have my Settings menu set to Expert. I scrolled through every menu category top to bottom, no matter how unrelated to video playback they might be. The closest thing I can find to something that might be hardware acceleration related is “Render method” under the Acceleration section of the Video settings, and as I said above it’s disabled-- it’s blacked out and permanently set to “Auto detect.” Is there a way I can use the linux console to change it, or manually change a settings file?

0 Likes

#17

Are you using OSMC skin? If not than change to OSMC skin for solving this. Share a screenshot of Settings->Player-Videos scrolled down to “Processing” section.

0 Likes

#18

Yes, I’m using the OSMC skin. I’m currently uploading pictures of my settings menu.

I tried Confluence, too, on the off chance maybe others were using that. Those are the only two skins included with OSMC by default. I’m running a clean installation-- nothing has been changed other than adding locations for files I’m attempting to play back.

0 Likes

#19

Ok so you are still on Kodi 16! I have to admit I joined this thread late and didn’t figured out that you haven’t upgraded to Kodi 17.
Than there might be a bit difference in the menu.

0 Likes

#20

I’ve been using the release numbers to describe the version I’m on (2017.01-1) but yeah, I’m still on 16 because HD video playback is broken on 17 for me. Well, ALL video playback is currently broken for me, so that makes little difference at the moment… Would it be worth updating to 17 and doing tests from there? I’m hesitant to do so because of the aforementioned HD playback problems. The VAST majority of my content is HD, so even if I can fix my current playback problems on a newer version, it wouldn’t be worth it because 17 can’t play my files properly anyway.

0 Likes

#21

Well reading in the other thread about the HD content issue I think the majority of files should work now but maybe not exactly the mix that you have. So I would be hesitant to suggest the upgrade. But on the other hand as in the moment

you don’t have anything to loose.

0 Likes