Vero Remote Eratic

Vero 1
Kodi (15.2)
Remote Battery Voltage 3.06

I’m using my Vero remote for the first time as I moved the Vero to a TV with no CEC.

I’m getting very erratic results from the remote.

For example, I see the following even though I only pressed the down key once:

osmc@Vero:~$ tail -F /home/osmc/.kodi/temp/kodi.log | grep OnKey
12:33:10 T:1957679104   DEBUG: OnKey: 167 (0xa7) pressed, action is Down
12:33:17 T:1957679104   DEBUG: OnKey: 167 (0xa7) pressed, action is Down
12:34:16 T:1957679104   DEBUG: OnKey: 167 (0xa7) pressed, action is Down
12:34:17 T:1957679104   DEBUG: OnKey: 167 (0xa7) pressed, action is Down

I have the Vero remote selected:

lrwxrwxrwx 1 root root 32 Feb 15 12:19 lircd.conf -> /etc/lirc/osmc-remote-lircd.conf

Some keys don’t work at all (play/pause), other keys result in multiple presses, as illustrated above.

What do I need to do to figure this out?


I’m adding another example of repeated keypresses:

4:44:58 T:1956974592   DEBUG: OnKey: 167 (0xa7) pressed, action is Down
14:45:04 T:1669547040   DEBUG: Previous line repeats 57 times.

Yeah, Down key pressed once and gets repeated 57 times….

And, the logs:

osmc@Vero:/etc/lirc$ sudo journalctl -b | paste-log
osmc@Vero:/etc/lirc$ paste-log /home/osmc/.kodi/temp/kodi.log

I see I’m not the only one experiencing this. See the end of this thread. Same problem, no response.

Remote Control Questions

Almost funny.

14:13:38 T:1956847616 DEBUG: OnKey: 166 (0xa6) pressed, action is Up
14:13:44 T:1956847616 DEBUG: Previous line repeats 57 times.

Can I take the deafening silence to indicate that this is an unresolvable hardware design error, sort of like the Vero WiFi?

Something we have to work around?

You appear to have a WiFi dongle attached in the back of the device which is causing performance problems

Have you unplugged the dongle and any other attached peripherals as a test?

The thread you linked to above doesn’t seem to suggest much, except that people have a habit of thread jacking. The user complaining about a slow remote may have been victim of the repeat filter, he doesn’t give enough of a description for us to follow up

Have you also tested the Vero WiFi recently? I believe @DBMandrake tested it a few days ago and found the WiFi much improved

I tried a WiFi dongle because the built-in WiFi performs so poorly. Oddly, the WiFi dongle didn’t improve things. I put the very same dongle on a Raspberry Pi and it performs perfectly.

Even without the WiFi dongle the remote is unusable.

Here’s what I tried:

  • Bought a new SD card
  • Downloaded the latest OSMC installer
  • Installed the OS specifying WiFi networking
  • Booted the Vero without a WiFi dongle

On the first boot I was unable to use the remote to configure the Vero. A single button press results in the OS seeing multiple keypresses. I finally used a USB keyboard to set up the Vero.

I configured everything from scratch and did not use any backed up configuration files.

I did not install any add-ons.

After all that, I still have the following problems:

  • Unusable remote
  • Dismal WiFi, with or without an external WiFi dongle
  • Painfully slow UI. Click on TV Shows and wait and wait for the list of shows to appear

I put a Raspberry Pi running OSMC in the exact same location with the exact same WiFi dongle and with a cheap USB remote. I get the following result:

  • The remote works fine
  • The WiFi works fine
  • The UI is snappy. No waiting for TV shows or episodes to load. Videos start playing instantly.

Honestly, I’m done fooling with this stuff.

Well, never mind. I’ve finally “retired” all of my OSMC devices.

Kind of sad, really, as I started out with this project in the days of Crystalbuntu on the original Apple TV. From there I moved on to Raspbmc, OSMC and the Vero.

The Vero was the killer for me. I realize I’m the only one out here who had trouble with the Vero, but I could just never get mine to work very well.

I finally decided that I was spending more time troubleshooting the Vero than I was watching videos on it. So, I junked it, bought an Apple TV 4 and installed MrMC. How refreshing. The Wifi just works. The remote just works. The UI is snappy and responsive. Videos start playing immediately.

I liked it so much that I repurposed my remaining Raspberry Pi and bought another Apple TV.

So, it’s adios. Don’t think it hasn’t been swell.