Vero remote on the Pi

I have a Vero but i don’t use the remote that came with it because we use a Harmony remote.
So i want tot use the Vero remote on my Pi1 with Osmc.

Can anyone tell witch USB ir receiver I need ?
( can’t find it separate in the store)


The TSOP38238 works really well for me with the white Vero remote on my Pi 2.

Keep in mind if your Vero and Pi are in the same (or possibly adjacent) room, the remote may operate both devices unless you choose a different remote in My OSMC->Remotes on the Vero.

So I bought the TSOP38238 and connected it the PI (model B).
Chose the Vero remote in OSMC but it does not respond.
The remote is oke because it works on the Vero and the Pi works fine with OSMC.
Did I miss something or is my TSOP broken (bought it new).

Anyone any ideas ?


Make sure GPIO IR remote is enabled in OSMC and make sure the OSMC remote profile is selected. You may need to restart

Also show us the pinouts that you are using - if it is not connected to the same pins that are configured in Pi config it will not work. (There is more than one pin configuration that can be used with an IR receiver)

So the pinouts are standard (1,6,12) and aren’t the problem.
The solution was to enable gpio ir in the config but when done from the gui it resulted in a rainbow screen.
After I had done a fresh install it all worked.

Thanks for the tips and support.


I think you have something else wrong there.

GPIO IR remote is enabled by default, and turning it off or on should (could) not cause it to get stuck on the rainbow screen.

With my first install (when OSMC was launched) I turned it off because I was using another remote (through USB).
For using the Vero remote with the TSOP38238 I turned it on but as I noticed the lines in the boot section off config.txt where not correct written witch resulted in a Rainbow screen.
After removing the lines OSMC booted normally.

I did a fresh install of OSMC and copied the GPIO lines in the config.txt to the excisting install and then it worked

There is no need to turn off Lirc GPIO support in Pi Config just because you are using a different remote. The only time you would need to disable it is if you have another GPIO device which needs to use the same GPIO pins, such as a Hifiberry.

What lines ? Can you paste a copy of the lines that were “not correct” ? Turning GPIO IR support back on in Pi config should not produce “lines that are not correct” that prevent the system booting.

Not a single other person has ever reported this.

To bad that my feedback is considered as not possible.
I did not save the broken config.txt on the boot partition.
Because I have the feeling that I have to defend myself instead of that it is taken as positive feedback I will not respond on this thread anymore.

Thanks for everyone’s response because it has solved my problem.


This is likely the resolution to your issue…

Chill out dude.

When you said that turning off GPIO lirc support was causing you to get stuck on the rainbow screen I said that this should not happen.

You then said that it had corrupted your config.txt and you had to manually fix it - I then asked you if you could post a copy of the lines which were not correct, but you did not reply for two days.

In the mean time we have discovered the cause of the problem ourselves and fixed it, which probably would have happened a day or two earlier if you had replied with a description of what was wrong with the config.txt as asked.

No need to get upset or defensive.