Vero screen randomly showing up

I’ve got this weird issue happening. 3 times so far, I’ve been watching a TV program on DirecTV and suddenly the screen will change to my Vero 4k+. As if the input changed. Haven’t got a clue what is causing it.


It looks like Kod is crashing for some reason.

To stop it changing the screen, go to Settings > System > Input > Peripherals and in CEC Adapter switch off the setting “Switch source to this device on startup”.

It seems like this started happening after the last update. I’ll try your suggestion, Thanks.

That setting dillthedog mentioned is not only just for if the device reboots. It is also responsible for allowing automatic input switching when you wake the device/start playing something/etc. Maybe you were sitting on the Vero’s remote?

So would you recommend not doing this?

No, wasn’t anywhere near the remotes.

I don’t have a recommend one way or the other as it is a cross between personal preference and how someone has their system setup. I was more trying to point out the fact that the setting being discussed was more than just when the system booted (like from a crash). The Vero could have some process in the background waking it up. It could also be some rf interference, or even some sunlight hitting the ir receiver that is waking it up. If you disable that your issue will likely go away and you won’t miss it. If you do miss it then we can try to figure it out.

You got a cat? They can be a bit devious sometimes. :smiley_cat: