Vero stuck in emergency mode - won't recognise the reinstall media in USB

Hi there,

I had a look through these forums but no-one seems to have the same issue I have. I have my Vero 4k+ stuck in emergency mode. Fine, I thought, just reinstall. So I downloaded the latest install media from the windows application and put it onto USB media. I inserted that USB media into the Vero when it was unplugged and… it just returns to the Emergency Shell screen.

I had a hunt around to see if I could find command line options to get it to read the media manually but I could not find any. That leaves me plum out of options other than to reach out to the wiser heads on these forums.

Thanks in advance

Yes, I have read that guide and followed its steps but - as my topic said - the unit won’t recognise the install media.

That’s why I’m posting here!

  • you’ve tried both usb port of the Vero?
  • any chance to let the installer prepare an sd card instead the usb stick?
  • can you show the content of the usb stick?

USB contents

I have tried both USB ports on the Vero, and have attached an image of the contents of the usb stick. I don’t have an SD card at the moment so that’s not an option.

Edit: these USB contents were created by the osmc windows installer

Just giving this a bump as it would nice to be able to kick my Vero into a functional mode again.

Content looks to be right, so

  • can you provide a foto/video of the screen with the emergency mode?
  • what type of USB media is it? brand/model
  • what else is connected to the usb ports of the Vero?


  • Photo attached
  • It’s a generic USB bought from the British Museum gift shop.
  • I’ve tried with a USB kb/m, with the Vero remote and with nothing else. No difference.

Is there not any kind of command line way to try and make the Vero see the stick and so begin the reinstall? Or is it a case that if it doesn’t auto-reinstall then it isn’t seeing the stick and the command line won’t help?

First I suggest to disable overscan (see below) on your TV so that the whole screen is visible not cut on the left.

Can you connect a keyboard and execute mount at the current prompt. Also can you execute ifconfig and show the picture.

  • Samsung TV - go to Menu / Picture / Picture Options / Size / Screen Fit (instead of 16:9).
  • LG TV - go to Settings / Picture / Aspect Ratio / Just Scan (instead of 16:9)
  • Sony TV - hit Home button, go to Settings / Screen / Display Area / Full Pixel
  • Sharp TV - hit View Mode button, select “Dot by Dot” or “Full screen”
  • Sharp Aquos - go to Menu / System Options / View Option / View Mode / Dot by Dot
  • Panasonic TV - go to Menu / Picture / Screen Settings / 16:9 Overscan / Off`

You could try the ‘toothpick’ method described here for older Veros.

Try re-name the kernel.img file to recovery.img and type ‘reboot recovery’ at the command line.

I literally had the same problem a couple of weeks back. the files on the USB stick were all correct too, but the Vero 4k+ just didnt seem to reinstall from it. like yours, this was a freebie USB stick from some conference.

switched to a SanDisk USB stick, re-ran the installer and it all worked fine, so my suggestion would be to try with a different USB stick.


Or an SD Card if @Ankle has that lying around.

another option would be to use the SD Association formatter to re-format the stick before running the installer.

Try re-name the kernel.img file to recovery.img and type ‘reboot recovery’ at the command line.

Did this first as I am in a rental with all my belongings in boxes so finding other install media would be a pain, but might be inevitable.

At any rate, this has brought progress of a kind. I am now stuck on the black ‘Please stand by’ screen. I have been here for five minutes so I think it’s safe to say that it’s hung at this point.

Another thing I did from the command line was fdisk -l, and the Vero definitely is aware the memory stick is in there. It just doesn’t want to play with it.

@fzinken Thanks for the overscan advice. Turned that off, and it’s a lot easier when you can see everything.

Alas, my situation has not improved. After the ‘Please Stand By’ hang that I got and described above, I now see this text when I power on the device, with or without the USB attached. This is not looking great :fearful:

I am concerned the Vero is now bricked.

Put those install files back on the USB stick with the installer or otherwise (if you saved them) and install again. It can require two goes. I don’t think you are bricked.

Mixed progress.

On the plus side, I dug out another USB stick and this one was recognised.

On the minus side:

I am getting that ‘one step forward, two steps back’ feeling.

Try the other USB port.

1 Like

Thank you @sam_nazarko, it was as simple as that.

To those seeing this thread after me, the best thing to do really is to try different install media. I don’t pretend to understand why this should be the case, but it definitely is. And then try both ports. As is witnessed by this thread, there is no other, easy way to get things moving.